summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-11 14:56:07 +0100
committerRemi Collet <remi@php.net>2023-12-11 14:56:07 +0100
commitdfc8be54d96ad6466c683f7594e93b54fd6f0f2c (patch)
tree57efe361bf9678ab69732e907fbba4fb1b1c4f17
parented21093e6a0d8a710c28f7f630caf18e78bd37a6 (diff)
update to 4.6.0
-rw-r--r--composer.json2
-rw-r--r--php-sabre-dav4-autoload.patch6
-rw-r--r--php-sabre-dav4.spec13
3 files changed, 13 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index a1296ed..3154173 100644
--- a/composer.json
+++ b/composer.json
@@ -34,7 +34,7 @@
},
"require-dev" : {
"friendsofphp/php-cs-fixer": "^2.19",
- "monolog/monolog": "^1.27",
+ "monolog/monolog": "^1.27 || ^2.0",
"phpstan/phpstan": "^0.12 || ^1.0",
"phpstan/phpstan-phpunit": "^1.0",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.6"
diff --git a/php-sabre-dav4-autoload.patch b/php-sabre-dav4-autoload.patch
index 9cdafef..f2d8cce 100644
--- a/php-sabre-dav4-autoload.patch
+++ b/php-sabre-dav4-autoload.patch
@@ -1,7 +1,7 @@
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
--- ./tests/bootstrap.php.rpm 2019-07-05 14:29:48.486775637 +0200
+++ ./tests/bootstrap.php 2019-07-05 14:32:02.171555393 +0200
-@@ -2,15 +2,11 @@
+@@ -2,15 +2,13 @@
declare(strict_types=1);
@@ -9,7 +9,9 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
-
-$autoLoader = include __DIR__.'/../vendor/autoload.php';
+require '@BUILDROOT@/usr/share/php/Sabre/DAV4/autoload.php';
-+require '/usr/share/php/Monolog/autoload.php';
++if (file_exists('/usr/share/php/Monolog2/autoload.php'))
++ require '/usr/share/php/Monolog2/autoload.php';
++else require '/usr/share/php/Monolog/autoload.php';
// SabreDAV tests auto loading
-$autoLoader->add('Sabre\\', __DIR__);
diff --git a/php-sabre-dav4.spec b/php-sabre-dav4.spec
index 1e11ce3..a6eb80e 100644
--- a/php-sabre-dav4.spec
+++ b/php-sabre-dav4.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit b29899b675371aee73920165d1dc5a2235aa104b
+%global gh_commit 554145304b4a026477d130928d16e626939b0b2a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project dav
@@ -24,7 +24,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: WebDAV Framework for PHP
-Version: 4.5.1
+Version: 4.6.0
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -49,7 +49,7 @@ BuildRequires: (php-composer(sabre/xml) >= 2.0.1 with php-composer(sabre/
BuildRequires: (php-composer(sabre/http) >= 5.0.5 with php-composer(sabre/http) < 6)
BuildRequires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri) < 3)
BuildRequires: (php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 4)
-BuildRequires: (php-composer(monolog/monolog) >= 1.27 with php-composer(monolog/monolog) < 2)
+BuildRequires: (php-composer(monolog/monolog) >= 1.27 with php-composer(monolog/monolog) < 3)
# remirepo:9
%else
BuildRequires: php-sabre-vobject4 >= 4.2.1
@@ -58,7 +58,7 @@ BuildRequires: php-sabre-xml2 >= 2.0.1
BuildRequires: php-sabre-http5 >= 5.0
BuildRequires: php-sabre-uri2 >= 2.0
BuildRequires: php-PsrLog >= 1.0.1
-BuildRequires: php-Monolog >= 1.18
+BuildRequires: php-Monolog >= 1.27
%endif
BuildRequires: php-dom
BuildRequires: php-pcre
@@ -74,7 +74,7 @@ BuildRequires: php-pdo
BuildRequires: php-json
# From composer.json, "require-dev" : {
# "friendsofphp/php-cs-fixer": "^2.19",
-# "monolog/monolog": "^1.27",
+# "monolog/monolog": "^1.27 || ^2.0",
# "phpstan/phpstan": "^0.12 || ^1.0",
# "phpstan/phpstan-phpunit": "^1.0",
# "phpunit/phpunit": "^7.5 || ^8.5 || ^9.6"
@@ -249,6 +249,9 @@ exit $ret
%changelog
+* Mon Dec 11 2023 Remi Collet <remi@remirepo.net> - 4.6.0-1
+- update to 4.6.0
+
* Thu Nov 23 2023 Remi Collet <remi@remirepo.net> - 4.5.1-1
- update to 4.5.1