summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-09 10:37:48 +0100
committerRemi Collet <remi@php.net>2021-12-09 10:37:48 +0100
commit58e154e0c6079c346f80f06e5da6cbd71c816384 (patch)
tree4a3c07874f6fd72e729b857db4c312ec1925bd72
parent7d405a005ba631c0ebb703979b39af51549dc105 (diff)
update to 4.2.2
allow psr/log v2 and v3
-rw-r--r--composer.json2
-rw-r--r--php-sabre-dav4.spec21
2 files changed, 15 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 7c9596d..5f0a44d 100644
--- a/composer.json
+++ b/composer.json
@@ -29,7 +29,7 @@
"ext-date" : "*",
"ext-iconv" : "*",
"lib-libxml" : ">=2.7.0",
- "psr/log": "^1.0",
+ "psr/log": "^1.0 || ^2.0 || ^3.0",
"ext-json": "*"
},
"require-dev" : {
diff --git a/php-sabre-dav4.spec b/php-sabre-dav4.spec
index 02d53a8..6c14ece 100644
--- a/php-sabre-dav4.spec
+++ b/php-sabre-dav4.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 5e651f9ddc2b05745f5b28cd697c8e8c6a0b6146
+%global gh_commit 5d739875d624e064018b4709ab544063df42d749
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project dav
@@ -24,7 +24,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: WebDAV Framework for PHP
-Version: 4.2.1
+Version: 4.2.2
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -48,8 +48,7 @@ BuildRequires: (php-composer(sabre/event) >= 5.0 with php-composer(sabre/
BuildRequires: (php-composer(sabre/xml) >= 2.0.1 with php-composer(sabre/xml) < 3)
BuildRequires: (php-composer(sabre/http) >= 5.0.5 with php-composer(sabre/http) < 6)
BuildRequires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri) < 3)
-BuildRequires: (php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 2)
-BuildRequires: (php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 2)
+BuildRequires: (php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 4)
BuildRequires: (php-composer(monolog/monolog) >= 1.18 with php-composer(monolog/monolog) < 2)
# remirepo:9
%else
@@ -108,7 +107,7 @@ BuildRequires: php-pdo_sqlite
# "ext-date" : "*",
# "ext-iconv" : "*",
# "lib-libxml" : ">=2.7.0",
-# "psr/log": "^1.0",
+# "psr/log": "^1.0 || ^2.0 || ^3.0",
# "ext-json": "*"
Requires: php(language) >= 7.1
# remirepo:1
@@ -118,7 +117,7 @@ Requires: (php-composer(sabre/event) >= 5.0 with php-composer(sabre/ev
Requires: (php-composer(sabre/xml) >= 2.0.1 with php-composer(sabre/xml) < 3)
Requires: (php-composer(sabre/http) >= 5.0.5 with php-composer(sabre/http) < 6)
Requires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri) < 3)
-Requires: (php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 2)
+Requires: (php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 4)
# remirepo:8
%else
Requires: php-sabre-vobject4 >= 4.2.1
@@ -197,7 +196,11 @@ cat << 'EOF' | tee -a lib/%{ns_project}%{major}/autoload.php
'%{_datadir}/php/%{ns_vendor}/Uri2/autoload.php',
'%{_datadir}/php/%{ns_vendor}/HTTP5/autoload.php',
'%{_datadir}/php/%{ns_vendor}/VObject4/autoload.php',
- '%{_datadir}/php/Psr/Log/autoload.php',
+ [
+ '%{_datadir}/php/Psr/Log3/autoload.php',
+ '%{_datadir}/php/Psr/Log2/autoload.php',
+ '%{_datadir}/php/Psr/Log/autoload.php',
+ ],
]);
EOF
@@ -252,6 +255,10 @@ exit $ret
%changelog
+* Thu Dec 9 2021 Remi Collet <remi@remirepo.net> - 4.2.2-1
+- update to 4.2.2
+- allow psr/log v2 and v3
+
* Tue Nov 30 2021 Remi Collet <remi@remirepo.net> - 4.2.1-1
- update to 4.2.1