summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-14 13:44:45 +0100
committerRemi Collet <remi@php.net>2023-11-14 13:44:45 +0100
commit0f1e8282a37cff6e40a0822c98db8f27a55d49ab (patch)
tree205b21604355a118b4282f243cc28354fbc64d66
parent5e859e5f73abe611881642d52aad1af8381fb957 (diff)
update to 4.5.0
-rw-r--r--composer.json23
-rw-r--r--php-sabre-dav4.spec31
2 files changed, 21 insertions, 33 deletions
diff --git a/composer.json b/composer.json
index 5f0a44d..a1296ed 100644
--- a/composer.json
+++ b/composer.json
@@ -33,11 +33,11 @@
"ext-json": "*"
},
"require-dev" : {
- "friendsofphp/php-cs-fixer": "^2.17.1",
- "phpstan/phpstan": "^0.12",
- "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0",
- "evert/phpdoc-md" : "~0.1.0",
- "monolog/monolog": "^1.18"
+ "friendsofphp/php-cs-fixer": "^2.19",
+ "monolog/monolog": "^1.27",
+ "phpstan/phpstan": "^0.12 || ^1.0",
+ "phpstan/phpstan-phpunit": "^1.0",
+ "phpunit/phpunit": "^7.5 || ^8.5 || ^9.6"
},
"suggest" : {
"ext-curl" : "*",
@@ -46,21 +46,12 @@
},
"autoload": {
"psr-4" : {
- "Sabre\\DAV\\" : "lib/DAV/",
- "Sabre\\DAVACL\\" : "lib/DAVACL/",
- "Sabre\\CalDAV\\" : "lib/CalDAV/",
- "Sabre\\CardDAV\\" : "lib/CardDAV/"
+ "Sabre\\" : "lib/"
}
},
"autoload-dev" : {
"psr-4" : {
- "Sabre\\" : "tests/Sabre/",
- "Sabre\\CalDAV\\" : "tests/Sabre/CalDAV",
- "Sabre\\CardDAV\\" : "tests/Sabre/CardDAV",
- "Sabre\\DAV\\" : "tests/Sabre/DAV",
- "Sabre\\DAV\\Property\\" : "tests/Sabre/DAV/Xml/Property",
- "Sabre\\DAVACL\\" : "tests/Sabre/DAVACL",
- "Sabre\\HTTP\\" : "tests/Sabre/HTTP"
+ "Sabre\\" : "tests/Sabre/"
}
},
"support" : {
diff --git a/php-sabre-dav4.spec b/php-sabre-dav4.spec
index b531c58..aa9611c 100644
--- a/php-sabre-dav4.spec
+++ b/php-sabre-dav4.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit b65362abc926520eda2c57e219f022a6c288069d
+%global gh_commit 7e40343e473f17eab3d1d6ca4ae3e1cdfc6e0fd8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project dav
@@ -24,7 +24,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: WebDAV Framework for PHP
-Version: 4.4.0
+Version: 4.5.0
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -49,7 +49,7 @@ BuildRequires: (php-composer(sabre/xml) >= 2.0.1 with php-composer(sabre/
BuildRequires: (php-composer(sabre/http) >= 5.0.5 with php-composer(sabre/http) < 6)
BuildRequires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri) < 3)
BuildRequires: (php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 4)
-BuildRequires: (php-composer(monolog/monolog) >= 1.18 with php-composer(monolog/monolog) < 2)
+BuildRequires: (php-composer(monolog/monolog) >= 1.27 with php-composer(monolog/monolog) < 2)
# remirepo:9
%else
BuildRequires: php-sabre-vobject4 >= 4.2.1
@@ -73,19 +73,13 @@ BuildRequires: php-curl
BuildRequires: php-pdo
BuildRequires: php-json
# From composer.json, "require-dev" : {
-# "friendsofphp/php-cs-fixer": "^2.17.1",
-# "phpstan/phpstan": "^0.12",
-# "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0",
-# "evert/phpdoc-md" : "~0.1.0",
-# "squizlabs/php_codesniffer": "~1.5.3"
-# "monolog/monolog": "^1.18"
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
-BuildRequires: phpunit9
+# "friendsofphp/php-cs-fixer": "^2.19",
+# "monolog/monolog": "^1.27",
+# "phpstan/phpstan": "^0.12 || ^1.0",
+# "phpstan/phpstan-phpunit": "^1.0",
+# "phpunit/phpunit": "^7.5 || ^8.5 || ^9.6"
+BuildRequires: phpunit9 >= 9.6
%global phpunit %{_bindir}/phpunit9
-%else
-BuildRequires: phpunit8
-%global phpunit %{_bindir}/phpunit8
-%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -178,7 +172,7 @@ Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php
%setup -q -n %{gh_project}-%{gh_commit}
mv lib/DAV/Browser/assets/openiconic/ICON-LICENSE .
-%patch0 -p1 -b .rpm
+%patch -P0 -p1 -b .rpm
: relocate
for dir in CalDAV CardDAV DAV DAVACL; do
@@ -226,7 +220,7 @@ sed -e 's:@BUILDROOT@:%{buildroot}:' -i bootstrap.php
: Run upstream test suite against installed library
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
for ts in sabre-dav sabre-davacl sabre-caldav sabre-carddav; do
@@ -255,6 +249,9 @@ exit $ret
%changelog
+* Tue Nov 14 2023 Remi Collet <remi@remirepo.net> - 4.5.0-1
+- update to 4.5.0
+
* Mon Jun 27 2022 Remi Collet <remi@remirepo.net> - 4.4.0-1
- update to 4.4.0