summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-17 18:27:54 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-17 18:27:54 +0200
commit77933296b20948b386613e760f0da4e4f394ac56 (patch)
tree66aed4dec461b60d33640e2c47f77b83f52d62c8
parent3cb6aa9d9d8de6ca0e8846990cdaec81102390de (diff)
php-robrichards-xmlseclibs: backport for remirepo
-rw-r--r--Makefile4
-rw-r--r--composer.json24
-rw-r--r--php-robrichards-xmlseclibs.spec25
3 files changed, 52 insertions, 1 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..a604b40
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,24 @@
+{
+ "name": "robrichards/xmlseclibs",
+ "description": "A PHP library for XML Security",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "xml",
+ "xmldsig",
+ "signature",
+ "security"
+ ],
+ "homepage": "https://github.com/robrichards/xmlseclibs",
+ "autoload": {
+ "psr-4": {
+ "RobRichards\\XMLSecLibs\\": "src"
+ }
+ },
+ "require": {
+ "php": ">= 5.3"
+ },
+ "suggest": {
+ "ext/openssl": "OpenSSL extension",
+ "ext/mcrypt": "MCrypt extension"
+ }
+}
diff --git a/php-robrichards-xmlseclibs.spec b/php-robrichards-xmlseclibs.spec
index 3dadaef..8f6f63f 100644
--- a/php-robrichards-xmlseclibs.spec
+++ b/php-robrichards-xmlseclibs.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-robrichards-xmlseclibs, from
#
# Fedora spec file for php-robrichards-xmlseclibs
#
@@ -36,6 +37,7 @@ License: BSD
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -118,6 +120,8 @@ AUTOLOAD
%install
+rm -rf %{buildroot}
+
mkdir -p %{buildroot}%{phpdir}/RobRichards/XMLSecLibs
cp -rp src/* %{buildroot}%{phpdir}/RobRichards/XMLSecLibs/
@@ -132,13 +136,29 @@ sed 's#require.*xmlseclibs.*#require_once "%{buildroot}%{phpdir}/RobRichards/XML
rm -f tests/extract-win-cert.phpt
: Run tests
-%{_bindir}/phpunit tests
+run=0
+if which php56; then
+ php56 %{_bindir}/phpunit tests
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit tests
+ run=1
+fi
+if [ $run -eq 0 ]; then
+ %{_bindir}/phpunit tests
+fi
%else
: Tests skipped
%endif
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc CHANGELOG.txt
@@ -149,6 +169,9 @@ rm -f tests/extract-win-cert.phpt
%changelog
+* Sun Jul 17 2016 Remi Collet <remi@remirepo.net> - 2.0.0-2.20160105git84313ca
+- backport for remi repository
+
* Thu Jul 14 2016 Shawn Iwinski <shawn@iwin.ski> - 2.0.0-2.20160105git84313ca
- Updated to latest snapshot
- Moved php-openssl from weak dependency to hard dependency