summaryrefslogtreecommitdiffstats
path: root/php-ringcentral-psr7.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-ringcentral-psr7.spec')
-rw-r--r--php-ringcentral-psr7.spec19
1 files changed, 14 insertions, 5 deletions
diff --git a/php-ringcentral-psr7.spec b/php-ringcentral-psr7.spec
index a0374da..5b8e2d0 100644
--- a/php-ringcentral-psr7.spec
+++ b/php-ringcentral-psr7.spec
@@ -1,7 +1,8 @@
+# remirepo spec file for php-ringcentral-psr7, from:
#
# Fedora spec file for php-ringcentral-psr7
#
-# Copyright (c) 2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2018-2021 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -11,8 +12,8 @@
%global github_owner ringcentral
%global github_name psr7
-%global github_version 1.2.2
-%global github_commit dcd84bbb49b96c616d1dcc8bfb9bef3f2cd53d1c
+%global github_version 1.3.0
+%global github_commit 360faaec4b563958b673fb52bbe94e37f14bc686
%global composer_vendor ringcentral
%global composer_project psr7
@@ -38,6 +39,9 @@ License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+# For PHP 8
+Patch0: %{name}-php8.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -91,7 +95,7 @@ Autoloader: %{phpdir}/RingCentral/Psr7/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
-
+%patch0 -p1
%build
: Create autoloader
@@ -126,7 +130,7 @@ ln -s %{buildroot}%{phpdir}/RingCentral/Psr7/autoload.php vendor/autoload.php
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in php %{?rhel:php54 php55 php56 php70 php71} php72 php73 php74 php80; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose || RETURN_CODE=1
fi
@@ -147,6 +151,11 @@ exit $RETURN_CODE
%changelog
+* Thu Nov 5 2020 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+- add patch for PHP 8 from
+ https://github.com/ringcentral/psr7/pull/8
+
* Sat Apr 21 2018 Shawn Iwinski <shawn@iwin.ski> - 1.2.2-1
- Update to 1.2.2
- Add range version dependencies for Fedora >= 27 || RHEL >= 8