summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--composer.json36
-rw-r--r--php-react.spec4
3 files changed, 44 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..cbdee52
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,36 @@
+{
+ "name": "react/react",
+ "description": "Nuclear Reactor written in PHP.",
+ "keywords": ["event-loop", "reactor", "asynchronous"],
+ "license": "MIT",
+ "support": {
+ "issues": "https://github.com/reactphp/react/issues",
+ "irc": "irc://irc.freenode.org/reactphp"
+ },
+ "require": {
+ "php": ">=5.4.0",
+ "react/cache": "0.4.*",
+ "react/child-process": "0.4.*",
+ "react/dns": "0.4.*",
+ "react/event-loop": "0.4.*",
+ "react/http-client": "0.4.*",
+ "react/http": "0.4.*",
+ "react/promise": "~2.1",
+ "react/socket-client": "0.4.*",
+ "react/socket": "0.4.*",
+ "react/stream": "0.4.*"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~4.0"
+ },
+ "suggest": {
+ "ext-libevent": "Allows for use of a more performant event-loop implementation.",
+ "ext-libev": "Allows for use of a more performant event-loop implementation.",
+ "ext-event": "Allows for use of a more performant event-loop implementation."
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "0.5-dev"
+ }
+ }
+}
diff --git a/php-react.spec b/php-react.spec
index 02e987c..683f5d7 100644
--- a/php-react.spec
+++ b/php-react.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-react, from:
#
# Fedora spec file for php-react
#
@@ -191,6 +192,9 @@ cp -p autoload.php %{buildroot}%{phpdir}/React/
%changelog
+* Mon Jan 30 2017 Remi Collet <remi@remirepo.net> - 0.4.2-2
+- backport
+
* Wed Jan 25 2017 Shawn Iwinski <shawn@iwin.ski> - 0.4.2-2
- Add missing php-cli BuildRequires