summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-29 16:17:21 +0100
committerRemi Collet <remi@php.net>2021-11-29 16:17:21 +0100
commitdca1577afaaf9a473407f8e8f549d7d9d24b0379 (patch)
treeb0b3e691a0004c50cd5363ed6bb1e0e08ce4f008
parent5776a15e795b7c30187145017a8d0e510963fa3e (diff)
update to 1.10.0
-rw-r--r--php-react-socket.spec24
1 files changed, 15 insertions, 9 deletions
diff --git a/php-react-socket.spec b/php-react-socket.spec
index 7383177..363809a 100644
--- a/php-react-socket.spec
+++ b/php-react-socket.spec
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name socket
-%global github_version 1.9.0
-%global github_commit aa6e3f8ebcd6dec3ad1ee92a449b4cc341994001
+%global github_version 1.10.0
+%global github_commit d132fde589ea97f4165f2d94b5296499eac125ec
%global composer_vendor react
%global composer_project socket
@@ -217,18 +217,21 @@ rm -f tests/IntegrationTest.php
: Skip "Class "React\Dns\Resolver\Resolver" is declared "final" and cannot be mocked" warnings
: Why is PHPUnit 6 failing the test run for this even if convertWarningsToExceptions="false"?
rm -f tests/DnsConnectorTest.php
-sed \
- -e 's/function testConnectorUsesGivenResolverInstance/function SKIP_testConnectorUsesGivenResolverInstance/' \
- -e 's/function testConnectorUsesResolvedHostnameIfDnsIsUsed/function SKIP_testConnectorUsesResolvedHostnameIfDnsIsUsed/' \
- -i tests/ConnectorTest.php
+FILTER="testConnectorUsesGivenResolverInstance|testConnectorUsesResolvedHostnameIfDnsIsUsed"
+%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9
+FILTER="$FILTER|testClientUsesTls10WhenCryptoMethodIsExplicitlyConfiguredByClient"
+%endif
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which %{phpunit_exec})
-for PHP_EXEC in "" php73 php74 php80; do
+for PHP_EXEC in "" php74 php80 php81; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php --exclude-group internet \
- || RETURN_CODE=1
+ $PHP_EXEC $PHPUNIT \
+ --bootstrap bootstrap.php \
+ --filter "^((?!($FILTER)).)*\$" \
+ --exclude-group internet \
+ --verbose || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -246,6 +249,9 @@ exit $RETURN_CODE
%changelog
+* Mon Nov 29 2021 Remi Collet <remi@remirepo.net> - 1.10.0-1
+- update to 1.10.0
+
* Wed Aug 4 2021 Remi Collet <remi@remirepo.net> - 1.9.0-1
- update to 1.9.0