summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-01-26 14:59:42 +0100
committerRemi Collet <fedora@famillecollet.com>2017-01-26 14:59:42 +0100
commit5c659d85632b98c69e552fa98fedf35c7df1f08b (patch)
treeb2907451b750c20d8d0dbe0ccd362253f00880c1
parent0db6f9dcff763ef5cc54082ed819357b3c97a84f (diff)
php-react-socket-client: backportHEADmaster
-rw-r--r--Makefile4
-rw-r--r--composer.json23
-rw-r--r--php-react-socket-client.spec4
3 files changed, 31 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..467cbef
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,23 @@
+{
+ "name": "react/socket-client",
+ "description": "Async connector to open TCP/IP and SSL/TLS based connections.",
+ "keywords": ["socket"],
+ "license": "MIT",
+ "require": {
+ "php": ">=5.4.0",
+ "react/dns": "0.4.*",
+ "react/event-loop": "0.4.*",
+ "react/stream": "0.4.*",
+ "react/promise": "~2.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "React\\SocketClient\\": "src"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "0.4-dev"
+ }
+ }
+}
diff --git a/php-react-socket-client.spec b/php-react-socket-client.spec
index 5adee96..20579f1 100644
--- a/php-react-socket-client.spec
+++ b/php-react-socket-client.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-react-socket-client, from:
#
# Fedora spec file for php-react-socket-client
#
@@ -160,6 +161,9 @@ exit $SCL_RETURN_CODE
%changelog
+* Thu Jan 26 2017 Remi Collet <remi@remirepo.net> - 0.4.6-3
+- backport
+
* Wed Jan 25 2017 Shawn Iwinski <shawn@iwin.ski> - 0.4.6-3
- Skip tests requiring network access