summaryrefslogtreecommitdiffstats
path: root/php-react-promise.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-react-promise.spec')
-rw-r--r--php-react-promise.spec26
1 files changed, 17 insertions, 9 deletions
diff --git a/php-react-promise.spec b/php-react-promise.spec
index 404a0b6..c3d7da5 100644
--- a/php-react-promise.spec
+++ b/php-react-promise.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-promise
#
-# Copyright (c) 2014-2019 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2014-2020 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name promise
-%global github_version 2.7.1
-%global github_commit 31ffa96f8d2ed0341a57848cbb84d88b89dd664d
+%global github_version 2.8.0
+%global github_commit f3cff96a19736714524ca0dd1d4130de73dbbbc4
%global composer_vendor react
%global composer_project promise
@@ -33,15 +33,19 @@ Summary: A lightweight implementation of CommonJS Promises/A for PHP
License: MIT
URL: https://reactphp.org/promise/
-Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+# GitHub export does not include tests
+# Run php-react-promise-get-source.sh to create full source
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: phpunit7
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-## phpcompatinfo (computed from version 2.7.1)
+## phpcompatinfo (computed from version 2.8.0)
BuildRequires: php-json
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -51,7 +55,7 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 2.7.1)
+# phpcompatinfo (computed from version 2.8.0)
Requires: php-json
Requires: php-reflection
Requires: php-spl
@@ -110,8 +114,8 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php55 php70} php71 php72 php73 php74; do
+PHPUNIT=$(which phpunit7)
+for PHP_EXEC in "" php72 php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -133,6 +137,10 @@ exit $RETURN_CODE
%changelog
+* Sat Jun 06 2020 Shawn Iwinski <shawn@iwin.ski> - 2.8.0-1
+- Update to 2.8.0 (RHBZ #1835048)
+- Use PHPUnit 7
+
* Sat Dec 14 2019 Shawn Iwinski <shawn@iwin.ski> - 2.7.1-1
- Update to 2.7.1