summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-16 15:24:54 +0100
committerRemi Collet <remi@remirepo.net>2019-12-16 15:24:54 +0100
commitdf4cf1435816fb530e107b1b509414a22e25c391 (patch)
tree8d1882f7c00bcb75c7bcc6a3a9c932b28f51b656
parent033c62443c9047fa5c2ea1e64651bb84e87404a2 (diff)
v1.5.1 from Fedora
-rw-r--r--composer.json2
-rw-r--r--php-react-promise-timer.spec19
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index a5ec626..1fdaddd 100644
--- a/composer.json
+++ b/composer.json
@@ -12,7 +12,7 @@
],
"autoload": {
"psr-4": { "React\\Promise\\Timer\\": "src/" },
- "files": [ "src/functions.php" ]
+ "files": [ "src/functions_include.php" ]
},
"autoload-dev": {
"psr-4": { "React\\Tests\\Promise\\Timer\\": "tests/" }
diff --git a/php-react-promise-timer.spec b/php-react-promise-timer.spec
index c3d4c73..cd17dd5 100644
--- a/php-react-promise-timer.spec
+++ b/php-react-promise-timer.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-promise-timer
#
-# Copyright (c) 2017-2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name promise-timer
-%global github_version 1.5.0
-%global github_commit a11206938ca2394dc7bb368f5da25cd4533fa603
+%global github_version 1.5.1
+%global github_commit 35fb910604fd86b00023fc5cda477c8074ad0abc
%global composer_vendor react
%global composer_project promise-timer
@@ -37,7 +37,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: Trivial timeout implementation for Promises
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -47,7 +46,7 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: phpunit6
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(react/event-loop) >= %{react_event_loop_min_ver} with php-composer(react/event-loop) < %{react_event_loop_max_ver})
BuildRequires: (php-composer(react/promise) >= %{react_promise_min_ver} with php-composer(react/promise) < %{react_promise_max_ver})
@@ -105,7 +104,7 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('React\\Promise\\Timer\\', __DIR__);
\Fedora\Autoloader\Dependencies::required(array(
- __DIR__.'/functions.php',
+ __DIR__.'/functions_include.php',
'%{phpdir}/React/EventLoop/autoload.php',
'%{phpdir}/React/Promise/autoload.php',
));
@@ -128,8 +127,8 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php70 php71 php72 php73; do
+PHPUNIT=$(which phpunit6)
+for PHP_EXEC in "" %{?rhel:php54 php55 php70} php71 php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -150,6 +149,10 @@ exit $RETURN_CODE
%changelog
+* Sat Dec 14 2019 Shawn Iwinski <shawn@iwin.ski> - 1.5.1-1
+- Update to 1.5.1 (RHBZ #1693418)
+- Use PHPUnit 6
+
* Sun Jul 01 2018 Shawn Iwinski <shawn@iwin.ski> - 1.5.0-1
- Update to 1.5.0 (RHBZ #1480034)
- Add range version dependencies for Fedora >= 27 || RHEL >= 8