summaryrefslogtreecommitdiffstats
path: root/php-react-promise-stream.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-react-promise-stream.spec')
-rw-r--r--php-react-promise-stream.spec21
1 files changed, 15 insertions, 6 deletions
diff --git a/php-react-promise-stream.spec b/php-react-promise-stream.spec
index 5730c60..c548027 100644
--- a/php-react-promise-stream.spec
+++ b/php-react-promise-stream.spec
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name promise-stream
-%global github_version 1.2.0
-%global github_commit 6384d8b76cf7dcc44b0bf3343fb2b2928412d1fe
+%global github_version 1.3.0
+%global github_commit 3ebd94fe0d8edbf44937948af28d02d5437e9949
%global composer_vendor react
%global composer_project promise-stream
@@ -48,14 +48,18 @@ Summary: The missing link between Promise-land and Stream-land for ReactPH
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+# GitHub export does not include tests
+# Run php-react-stream-get-source.sh to create full source
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-sources.sh
BuildArch: noarch
# Tests
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: phpunit7
+BuildRequires: phpunit9 >= 9.3
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(clue/block-react) >= %{clue_block_react_min_ver} with php-composer(clue/block-react) < %{clue_block_react_max_ver})
BuildRequires: (php-composer(react/event-loop) >= %{react_event_loop_min_ver} with php-composer(react/event-loop) < %{react_event_loop_max_ver})
@@ -155,8 +159,9 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit7)
-for PHP_EXEC in "" php71 php72 php73 php74; do
+PHPUNIT=$(which phpunit9)
+# TODO PHP 8
+for PHP_EXEC in "" php73 php74 php80 php81; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -177,6 +182,10 @@ exit $RETURN_CODE
%changelog
+* Thu Oct 21 2021 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+- switch to phpunit9
+
* Sat Dec 14 2019 Shawn Iwinski <shawn@iwin.ski> - 1.2.0-1
- Update to 1.2.0 (RHBZ #1783720)
- Use PHPUnit 7