summaryrefslogtreecommitdiffstats
path: root/php-react-http.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-react-http.spec')
-rw-r--r--php-react-http.spec15
1 files changed, 12 insertions, 3 deletions
diff --git a/php-react-http.spec b/php-react-http.spec
index 69407a4..c136e0e 100644
--- a/php-react-http.spec
+++ b/php-react-http.spec
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name http
-%global github_version 1.2.0
-%global github_commit badb0a87890e14b9cdfa3aec3ba1aafd900401ac
+%global github_version 1.3.0
+%global github_commit bc537273d11ee769c723a830e63aa33c0c35a530
%global composer_vendor react
%global composer_project http
@@ -236,12 +236,18 @@ require '%{buildroot}%{phpdir}/React/Http/autoload.php';
));
BOOTSTRAP
+: Skip test requiring network access and/or fail in restrictive buildroot env -- i.e. Bodhi
+FILTER="testSuccessfulResponseEmitsEnd|testPostDataReturnsData|testPostJsonReturnsData\
+|testCanAccessHttps|testVerifyPeerDisabledForBadSslResolves|testCancelPendingConnectionEmitsClose"
+
: Upstream tests
RETURN_CODE=0
for CMDARG in "php %{phpunit}" "php72 %{_bindir}/phpunit" php73 php74 php80; do
if which $CMDARG; then
set $CMDARG
- $1 ${2:-%{_bindir}/phpunit9} --verbose \
+ $1 ${2:-%{_bindir}/phpunit9} \
+ --filter "^((?!($FILTER)).)*\$" \
+ --verbose \
|| RETURN_CODE=1
fi
done
@@ -260,6 +266,9 @@ exit $RETURN_CODE
%changelog
+* Tue Apr 13 2021 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+
* Mon Dec 7 2020 Remi Collet <remi@remirepo.net> - 1.2.0-1
- update to 1.2.0