summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShawn Iwinski <shawn@iwin.ski>2017-04-08 15:46:07 -0400
committerRemi Collet <remi@remirepo.net>2017-04-10 09:14:18 +0200
commitb9d5d5670138a8e432830456eeb79c1f224ea86a (patch)
tree0763ca566a88dc41ca2cfb563a489e083d7b70d7
parent447d71ddcb35caad3204102e44f7a257ea760c0d (diff)
Update to 0.4.17 (RHBZ #1434200)
(cherry picked from commit 3ee8f8b8dc3d17cc3136936e3973e0dac4c387b7)
-rw-r--r--.gitignore3
-rw-r--r--php-react-http-client.spec25
2 files changed, 16 insertions, 12 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..18479e5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/php-react-http-client-0.4.15-01e919008363622334f91419a9908b3a51754ccd.tar.gz
+/php-react-http-client-0.4.16-307d8f9c9062c9f2fb21cde6ad13afee040cce15.tar.gz
+/php-react-http-client-0.4.17-75ee8a113f156834aaabfe0055e8db531cb4892c.tar.gz
diff --git a/php-react-http-client.spec b/php-react-http-client.spec
index c80c2fb..33267ae 100644
--- a/php-react-http-client.spec
+++ b/php-react-http-client.spec
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name http-client
-%global github_version 0.4.16
-%global github_commit 307d8f9c9062c9f2fb21cde6ad13afee040cce15
+%global github_version 0.4.17
+%global github_commit 75ee8a113f156834aaabfe0055e8db531cb4892c
%global composer_vendor react
%global composer_project http-client
@@ -77,7 +77,7 @@ BuildRequires: php-composer(react/socket-client) < %{react_socket_client_max_ve
BuildRequires: php-composer(react/socket-client) >= %{react_socket_client_min_ver}
BuildRequires: php-composer(react/stream) < %{react_stream_max_ver}
BuildRequires: php-composer(react/stream) >= %{react_stream_min_ver}
-## phpcompatinfo (computed from version 0.4.16)
+## phpcompatinfo (computed from version 0.4.17)
BuildRequires: php-json
BuildRequires: php-spl
## Autoloader
@@ -100,7 +100,7 @@ Requires: php-composer(react/socket-client) < %{react_socket_client_max_ve
Requires: php-composer(react/socket-client) >= %{react_socket_client_min_ver}
Requires: php-composer(react/stream) < %{react_stream_max_ver}
Requires: php-composer(react/stream) >= %{react_stream_min_ver}
-# phpcompatinfo (computed from version 0.4.16)
+# phpcompatinfo (computed from version 0.4.17)
Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -157,16 +157,14 @@ require '%{buildroot}%{phpdir}/React/HttpClient/autoload.php';
BOOTSTRAP
: Upstream tests
-%{_bindir}/phpunit --verbose --bootstrap bootstrap.php
-
-: Upstream tests with SCLs if available
-SCL_RETURN_CODE=0
-for SCL in %{?rhel:php55} php56 php70 php71; do
- if which $SCL; then
- $SCL %{_bindir}/phpunit --verbose --bootstrap bootstrap.php || SCL_RETURN_CODE=1
+RETURN_CODE=0
+for PHP_EXEC in php %{?rhel:php55} php56 php70 php71; do
+ if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC %{_bindir}/phpunit --bootstrap bootstrap.php --verbose \
+ || RETURN_CODE=1
fi
done
-exit $SCL_RETURN_CODE
+exit $RETURN_CODE
%else
: Tests skipped
%endif
@@ -181,6 +179,9 @@ exit $SCL_RETURN_CODE
%changelog
+* Sat Apr 08 2017 Shawn Iwinski <shawn@iwin.ski> - 0.4.17-1
+- Update to 0.4.17 (RHBZ #1434200)
+
* Sat Mar 11 2017 Shawn Iwinski <shawn@iwin.ski> - 0.4.16-1
- Update to 0.4.16 (RHBZ #1429266)