summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-01-26 15:04:44 +0100
committerRemi Collet <fedora@famillecollet.com>2017-01-26 15:04:44 +0100
commitb5d26de7b5678734b6fea09c0f9026e64101938b (patch)
tree96c45fa06392f5e6d8c0708485064c684eb2ae07
parent1672260c6cb7d368e97140731e85a43360d53a3f (diff)
php-react-http-client: backport
-rw-r--r--Makefile4
-rw-r--r--composer.json21
-rw-r--r--php-react-http-client.spec4
3 files changed, 29 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..4939a69
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,21 @@
+{
+ "name": "react/http-client",
+ "description": "Asynchronous HTTP client library.",
+ "keywords": ["http"],
+ "license": "MIT",
+ "require": {
+ "php": ">=5.4.0",
+ "guzzlehttp/psr7": "^1.0",
+ "react/socket-client": "^0.5 || ^0.4 || ^0.3",
+ "react/dns": "0.4.*",
+ "react/event-loop": "0.4.*",
+ "react/stream": "0.4.*",
+ "react/promise": "~2.2",
+ "evenement/evenement": "~2.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "React\\HttpClient\\": "src"
+ }
+ }
+}
diff --git a/php-react-http-client.spec b/php-react-http-client.spec
index 8b65269..0786545 100644
--- a/php-react-http-client.spec
+++ b/php-react-http-client.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-react-http-client, from:
#
# Fedora spec file for php-react-http-client
#
@@ -180,6 +181,9 @@ exit $SCL_RETURN_CODE
%changelog
+* Thu Jan 26 2017 Remi Collet <remi@remirepo.net> - 0.4.15-2
+- backport
+
* Wed Jan 25 2017 Shawn Iwinski <shawn@iwin.ski> - 0.4.15-2
- Minor update to SCL tests (only php55 if rhel)