summaryrefslogtreecommitdiffstats
path: root/php-react-dns.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-react-dns.spec')
-rw-r--r--php-react-dns.spec18
1 files changed, 9 insertions, 9 deletions
diff --git a/php-react-dns.spec b/php-react-dns.spec
index 99714ee..9ea1c70 100644
--- a/php-react-dns.spec
+++ b/php-react-dns.spec
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name dns
-%global github_version 1.8.0
-%global github_commit 2a5a74ab751e53863b45fb87e1d3913884f88248
+%global github_version 1.9.0
+%global github_commit 6d38296756fa644e6cb1bfe95eff0f9a4ed6edcb
%global composer_vendor react
%global composer_project dns
@@ -33,8 +33,8 @@
# ignore v3 not yet packaged
%global react_promise_min_ver 1.2.1
%global react_promise_max_ver 3.0
-# "react/promise-timer": "^1.2"
-%global react_promise_timer_min_ver 1.2
+# "react/promise-timer": "^1.8"
+%global react_promise_timer_min_ver 1.8
%global react_promise_timer_max_ver 2.0
# Build using "--without tests" to disable tests
@@ -55,9 +55,6 @@ URL: https://reactphp.org/dns/
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
-# Filter valid IPs
-Patch0: https://patch-diff.githubusercontent.com/raw/reactphp/dns/pull/181.patch
-
BuildArch: noarch
# Tests
%if %{with tests}
@@ -136,7 +133,6 @@ Autoloader: %{phpdir}/React/Dns/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
-%patch0 -p1
%build
@@ -192,7 +188,7 @@ VER=$(php -r 'echo PHP_INT_SIZE;')
: Upstream tests
RETURN_CODE=0
-for CMDARG in "php %{phpunit}" php73 php74 php80 php81; do
+for CMDARG in "php %{phpunit}" php74 php80 php81; do
if which $CMDARG; then
set $CMDARG
$1 ${2:-%{_bindir}/phpunit9} -d memory_limit=-1 \
@@ -216,6 +212,10 @@ exit $RETURN_CODE
%changelog
+* Mon Dec 20 2021 Remi Collet <remi@remirepo.net> - 1.9.0-1
+- update to 1.9.0
+- raise dependency on react/promise-timer 1.8
+
* Mon Jul 12 2021 Remi Collet <remi@remirepo.net> - 1.8.0-1
- update to 1.8.0
- raise dependency on react/event-loop 1.2