summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json26
l---------makesrc.sh1
-rwxr-xr-xphp-react-child-process-get-source.sh74
-rw-r--r--php-react-child-process.spec48
4 files changed, 129 insertions, 20 deletions
diff --git a/composer.json b/composer.json
index 3e6a8fe..bdaa7a8 100644
--- a/composer.json
+++ b/composer.json
@@ -3,6 +3,28 @@
"description": "Event-driven library for executing child processes with ReactPHP.",
"keywords": ["process", "event-driven", "ReactPHP"],
"license": "MIT",
+ "authors": [
+ {
+ "name": "Christian Lück",
+ "homepage": "https://clue.engineering/",
+ "email": "christian@clue.engineering"
+ },
+ {
+ "name": "Cees-Jan Kiewiet",
+ "homepage": "https://wyrihaximus.net/",
+ "email": "reactphp@ceesjankiewiet.nl"
+ },
+ {
+ "name": "Jan Sorgalla",
+ "homepage": "https://sorgalla.com/",
+ "email": "jsorgalla@gmail.com"
+ },
+ {
+ "name": "Chris Boden",
+ "homepage": "https://cboden.dev/",
+ "email": "cboden@gmail.com"
+ }
+ ],
"require": {
"php": ">=5.3.0",
"evenement/evenement": "^3.0 || ^2.0 || ^1.0",
@@ -10,9 +32,9 @@
"react/stream": "^1.0 || ^0.7.6"
},
"require-dev": {
- "phpunit/phpunit": "^7.0 || ^6.4 || ^5.7 || ^4.8.35",
+ "phpunit/phpunit": "^9.3 || ^5.7 || ^4.8.35",
"react/socket": "^1.0",
- "sebastian/environment": "^3.0 || ^2.0 || ^1.0"
+ "sebastian/environment": "^5.0 || ^3.0 || ^2.0 || ^1.0"
},
"autoload": {
"psr-4": { "React\\ChildProcess\\": "src" }
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..7b1a633
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-react-cache-get-source.sh \ No newline at end of file
diff --git a/php-react-child-process-get-source.sh b/php-react-child-process-get-source.sh
new file mode 100755
index 0000000..8b02c4f
--- /dev/null
+++ b/php-react-child-process-get-source.sh
@@ -0,0 +1,74 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+SPEC_DIR=`pwd`
+
+print "SPEC_DIR = $SPEC_DIR"
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ cp composer.json ${SPEC_DIR}/
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ TAR_FILE=${SPEC_DIR}/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-react-child-process.spec b/php-react-child-process.spec
index ba69bb7..2c872aa 100644
--- a/php-react-child-process.spec
+++ b/php-react-child-process.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-child-process
#
-# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2021 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name child-process
-%global github_version 0.6.1
-%global github_commit 6895afa583d51dc10a4b9e93cd3bce17b3b77ac3
+%global github_version 0.6.2
+%global github_commit 70486012c0265264d2afa489ff32e7cdb76000d9
%global composer_vendor react
%global composer_project child-process
@@ -32,9 +32,9 @@
# "react/stream": "^1.0 || ^0.7.6"
%global react_stream_min_ver 0.7.6
%global react_stream_max_ver 2.0
-# "sebastian/environment": "^3.0 || ^2.0 || ^1.0"
+# "sebastian/environment": "^5.0 || ^3.0 || ^2.0 || ^1.0"
%global sebastian_environment_min_ver 1.0
-%global sebastian_environment_max_ver 4.0
+%global sebastian_environment_max_ver 6
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -48,14 +48,25 @@ Summary: Library for executing child processes
License: MIT
URL: https://reactphp.org/child-process/
-Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+# GitHub export does not include tests
+# Run php-react-cache-get-source.sh to create full source
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
BuildArch: noarch
# Tests
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: phpunit7
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+# "phpunit/phpunit": "^9.3 || ^5.7 || ^4.8.35"
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
+%else
+%global phpunit %{_bindir}/phpunit
+BuildRequires: php-phpunit-PHPUnit >= 4.8.35
+%endif
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(evenement/evenement) >= %{evenement_min_ver} with php-composer(evenement/evenement) < %{evenement_max_ver})
BuildRequires: (php-composer(react/event-loop) >= %{react_event_loop_min_ver} with php-composer(react/event-loop) < %{react_event_loop_max_ver})
@@ -143,19 +154,15 @@ cp -rp src %{buildroot}%{phpdir}/React/ChildProcess
%check
%if %{with_tests}
: Create tests bootstrap
-cat <<'BOOTSTRAP' | tee bootstrap.php
+mkdir vendor
+cat <<'BOOTSTRAP' | tee vendor/autoload.php
<?php
require '%{buildroot}%{phpdir}/React/ChildProcess/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('React\\Tests\\ChildProcess\\', __DIR__.'/tests');
+\Fedora\Autoloader\Autoload::addPsr4('React\\Tests\\ChildProcess\\', dirname(__DIR__).'/tests');
\Fedora\Autoloader\Dependencies::required(array(
'%{phpdir}/React/Socket/autoload.php',
- array(
- '%{phpdir}/SebastianBergmann/Environment3/autoload.php',
- '%{phpdir}/SebastianBergmann/Environment2/autoload.php',
- '%{phpdir}/SebastianBergmann/Environment/autoload.php',
- ),
));
BOOTSTRAP
@@ -165,10 +172,10 @@ sed 's/function testProcessPidNotSameDueToShellWrapper/function SKIP_testProcess
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit7)
-for PHP_EXEC in "" php71 php72 php73 php74; do
- if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
+for CMDARG in "php %{phpunit}" "php72 %{_bindir}/phpunit" php73 php80; do
+ if which $CMDARG; then
+ set $CMDARG
+ $1 ${2:-%{_bindir}/phpunit9} --verbose \
|| RETURN_CODE=1
fi
done
@@ -187,6 +194,11 @@ exit $RETURN_CODE
%changelog
+* Fri Feb 5 2021 Remi Collet <remi@remirepo.net> - 0.6.2-1
+- update to 0.6.2
+- switch to phpunit9
+- sources from git snapshot
+
* Sat Dec 14 2019 Shawn Iwinski <shawn@iwin.ski> - 0.6.1-1
- Update to 0.6.1 (RHBZ #1677881)
- Use PHPUnit 7