summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-ramsey-uuid.spec14
2 files changed, 11 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 9ea4e06..8139b54 100644
--- a/composer.json
+++ b/composer.json
@@ -11,7 +11,7 @@
"require": {
"php": "^8.0",
"ext-json": "*",
- "brick/math": "^0.8.8 || ^0.9 || ^0.10 || ^0.11",
+ "brick/math": "^0.8.8 || ^0.9 || ^0.10 || ^0.11 || ^0.12",
"ramsey/collection": "^1.2 || ^2.0"
},
"require-dev": {
diff --git a/php-ramsey-uuid.spec b/php-ramsey-uuid.spec
index 20ab989..d186b9a 100644
--- a/php-ramsey-uuid.spec
+++ b/php-ramsey-uuid.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 60a4c63ab724854332900504274f6150ff26d286
+%global gh_commit 91039bc1faa45ba123c4328958e620d382ec7088
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner ramsey
%global gh_project uuid
@@ -22,7 +22,7 @@
%global ns_project Uuid
Name: php-%{pk_vendor}-%{pk_name}
-Version: 4.7.4
+Version: 4.7.6
Release: 1%{?dist}
Summary: Library for generating and working with UUIDs
@@ -83,7 +83,7 @@ BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": "^8.0",
# "ext-json": "*",
-# "brick/math": "^0.8.8 || ^0.9 || ^0.10 || ^0.11",
+# "brick/math": "^0.8.8 || ^0.9 || ^0.10 || ^0.11 || ^0.12",
# "ramsey/collection": "^1.2 || ^2.0",
Requires: php(language) >= 8.0
Requires: php-json
@@ -165,7 +165,7 @@ rm tests/Generator/RandomLibAdapterTest.php
: Run upstream test suite
ret=0
-for cmdarg in "php %{?phpunit}" php80 php81 php82; do
+for cmdarg in "php %{?phpunit}" php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -188,6 +188,12 @@ exit $ret
%changelog
+* Thu May 2 2024 Remi Collet <remi@remirepo.net> - 4.7.6-1
+- update to 4.7.6
+
+* Wed Nov 8 2023 Remi Collet <remi@remirepo.net> - 4.7.5-1
+- update to 4.7.5
+
* Wed Apr 19 2023 Remi Collet <remi@remirepo.net> - 4.7.4-1
- update to 4.7.4