summaryrefslogtreecommitdiffstats
path: root/php-ramsey-uuid.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-28 13:36:10 +0200
committerRemi Collet <remi@php.net>2022-03-28 13:36:10 +0200
commita9d1d8203a0477b613d7686291e98bf0dc916cc3 (patch)
tree287e7646528b746167103dfe38c019dc8f2b2394 /php-ramsey-uuid.spec
parentf90d5c7ccec759995e8e308ef116ba3ccf07d1c5 (diff)
update to 4.3.1
raise dependency on PHP 8.0 drop dependency on php-symfony-polyfill
Diffstat (limited to 'php-ramsey-uuid.spec')
-rw-r--r--php-ramsey-uuid.spec29
1 files changed, 14 insertions, 15 deletions
diff --git a/php-ramsey-uuid.spec b/php-ramsey-uuid.spec
index 1c02fb4..d434497 100644
--- a/php-ramsey-uuid.spec
+++ b/php-ramsey-uuid.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit fc9bb7fb5388691fd7373cd44dcb4d63bbcf24df
+%global gh_commit 8505afd4fea63b81a85d3b7b53ac3cb8dc347c28
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner ramsey
%global gh_project uuid
@@ -22,7 +22,7 @@
%global ns_project Uuid
Name: php-%{pk_vendor}-%{pk_name}
-Version: 4.2.3
+Version: 4.3.1
Release: 1%{?dist}
Summary: Library for generating and working with UUIDs
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 7.2
+BuildRequires: php(language) >= 8.0
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-hash
@@ -67,14 +67,12 @@ BuildRequires: php-spl
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(brick/math) >= 0.8 with php-composer(brick/math) < 0.10)
BuildRequires: (php-composer(ramsey/collection) >= 1.0 with php-composer(ramsey/collection) < 2)
-BuildRequires: (php-composer(symfony/polyfill-php80) >= 1.14 with php-composer(symfony/polyfill-php80) < 2)
BuildRequires: (php-composer(mockery/mockery) >= 1.3 with php-composer(mockery/mockery) < 2)
BuildRequires: (php-composer(php-mock/php-mock) >= 2.2 with php-composer(php-mock/php-mock) < 3)
-# remirepo:7
+# remirepo:6
%else
BuildRequires: php-brick-math >= 0.8
BuildRequires: php-ramsey-collection >= 1.0
-BuildRequires: php-symfony-polyfill >= 1.14
BuildRequires: php-mockery >= 1.3
BuildRequires: php-mock2 >= 2.2
%endif
@@ -85,25 +83,22 @@ BuildRequires: phpunit9
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^7.2 || ^8.0",
+# "php": "^8.0",
+# "ext-ctype": "*",
# "ext-json": "*",
# "brick/math": "^0.8 || ^0.9",
# "ramsey/collection": "^1.0",
-# "symfony/polyfill-ctype": "^1.8"
-# "symfony/polyfill-php80": "^1.14"
-Requires: php(language) >= 7.2
+Requires: php(language) >= 8.0
Requires: php-ctype
Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(brick/math) >= 0.8 with php-composer(brick/math) < 0.10)
Requires: (php-composer(ramsey/collection) >= 1.0 with php-composer(ramsey/collection) < 2)
-Requires: (php-composer(symfony/polyfill-php80) >= 1.14 with php-composer(symfony/polyfill-php80) < 2)
-# remirepo:5
+# remirepo:4
%else
Requires: php-brick-math >= 0.8
Requires: php-ramsey-collection >= 1.0
-Requires: php-symfony-polyfill >= 1.14
%endif
# From phpcompatifo report for 4.1.1
Requires: php-date
@@ -139,7 +134,6 @@ cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
'%{_datadir}/php/Brick/Math/autoload.php',
'%{_datadir}/php/Ramsey/Collection/autoload.php',
- '%{_datadir}/php/Symfony/Polyfill/autoload.php',
__DIR__ . '/functions.php',
]);
EOF
@@ -174,7 +168,7 @@ rm tests/Generator/RandomLibAdapterTest.php
: Run upstream test suite
ret=0
-for cmdarg in "php %{?phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{?phpunit}" php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -197,6 +191,11 @@ exit $ret
%changelog
+* Mon Mar 28 2022 Remi Collet <remi@remirepo.net> - 4.3.1-1
+- update to 4.3.1
+- raise dependency on PHP 8.0
+- drop dependency on php-symfony-polyfill
+
* Mon Sep 27 2021 Remi Collet <remi@remirepo.net> - 4.2.3-1
- update to 4.2.3
- add dependency on php-symfony-polyfill