summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-27 06:47:41 +0200
committerRemi Collet <remi@remirepo.net>2021-09-27 06:47:41 +0200
commitf90d5c7ccec759995e8e308ef116ba3ccf07d1c5 (patch)
tree677592b935a3c4870e64382fbb03b97be074ad9a
parent6dedade721757c6c42bd068fde20016e667b3d50 (diff)
update to 4.2.3
add dependency on php-symfony-polyfill
-rw-r--r--composer.json5
-rw-r--r--php-ramsey-uuid.spec34
2 files changed, 25 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index a29d483..3f3b5ac 100644
--- a/composer.json
+++ b/composer.json
@@ -9,11 +9,12 @@
],
"license": "MIT",
"require": {
- "php": "^7.2 || ^8",
+ "php": "^7.2 || ^8.0",
"ext-json": "*",
"brick/math": "^0.8 || ^0.9",
"ramsey/collection": "^1.0",
- "symfony/polyfill-ctype": "^1.8"
+ "symfony/polyfill-ctype": "^1.8",
+ "symfony/polyfill-php80": "^1.14"
},
"replace": {
"rhumsaa/uuid": "self.version"
diff --git a/php-ramsey-uuid.spec b/php-ramsey-uuid.spec
index 5629f2b..1c02fb4 100644
--- a/php-ramsey-uuid.spec
+++ b/php-ramsey-uuid.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit fe665a03df4f056aa65af552a96e1976df8c8dae
+%global gh_commit fc9bb7fb5388691fd7373cd44dcb4d63bbcf24df
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner ramsey
%global gh_project uuid
@@ -22,7 +22,7 @@
%global ns_project Uuid
Name: php-%{pk_vendor}-%{pk_name}
-Version: 4.2.1
+Version: 4.2.3
Release: 1%{?dist}
Summary: Library for generating and working with UUIDs
@@ -65,14 +65,16 @@ BuildRequires: php-spl
%if %{with tests}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(brick/math) >= 0.8 with php-composer(brick/math) < 0.10)
-BuildRequires: (php-composer(ramsey/collection) >= 1.0 with php-composer(ramsey/collection) < 2)
-BuildRequires: (php-composer(mockery/mockery) >= 1.3 with php-composer(mockery/mockery) < 2)
-BuildRequires: (php-composer(php-mock/php-mock) >= 2.2 with php-composer(php-mock/php-mock) < 3)
-# remirepo:6
+BuildRequires: (php-composer(brick/math) >= 0.8 with php-composer(brick/math) < 0.10)
+BuildRequires: (php-composer(ramsey/collection) >= 1.0 with php-composer(ramsey/collection) < 2)
+BuildRequires: (php-composer(symfony/polyfill-php80) >= 1.14 with php-composer(symfony/polyfill-php80) < 2)
+BuildRequires: (php-composer(mockery/mockery) >= 1.3 with php-composer(mockery/mockery) < 2)
+BuildRequires: (php-composer(php-mock/php-mock) >= 2.2 with php-composer(php-mock/php-mock) < 3)
+# remirepo:7
%else
BuildRequires: php-brick-math >= 0.8
BuildRequires: php-ramsey-collection >= 1.0
+BuildRequires: php-symfony-polyfill >= 1.14
BuildRequires: php-mockery >= 1.3
BuildRequires: php-mock2 >= 2.2
%endif
@@ -83,22 +85,25 @@ BuildRequires: phpunit9
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^7.2 || ^8",
+# "php": "^7.2 || ^8.0",
# "ext-json": "*",
# "brick/math": "^0.8 || ^0.9",
# "ramsey/collection": "^1.0",
# "symfony/polyfill-ctype": "^1.8"
+# "symfony/polyfill-php80": "^1.14"
Requires: php(language) >= 7.2
Requires: php-ctype
Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(brick/math) >= 0.8 with php-composer(brick/math) < 0.10)
-Requires: (php-composer(ramsey/collection) >= 1.0 with php-composer(ramsey/collection) < 2)
-# remirepo:4
+Requires: (php-composer(brick/math) >= 0.8 with php-composer(brick/math) < 0.10)
+Requires: (php-composer(ramsey/collection) >= 1.0 with php-composer(ramsey/collection) < 2)
+Requires: (php-composer(symfony/polyfill-php80) >= 1.14 with php-composer(symfony/polyfill-php80) < 2)
+# remirepo:5
%else
Requires: php-brick-math >= 0.8
Requires: php-ramsey-collection >= 1.0
+Requires: php-symfony-polyfill >= 1.14
%endif
# From phpcompatifo report for 4.1.1
Requires: php-date
@@ -134,6 +139,7 @@ cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
'%{_datadir}/php/Brick/Math/autoload.php',
'%{_datadir}/php/Ramsey/Collection/autoload.php',
+ '%{_datadir}/php/Symfony/Polyfill/autoload.php',
__DIR__ . '/functions.php',
]);
EOF
@@ -168,7 +174,7 @@ rm tests/Generator/RandomLibAdapterTest.php
: Run upstream test suite
ret=0
-for cmdarg in "php %{?phpunit}" php73 php74 php80; do
+for cmdarg in "php %{?phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -191,6 +197,10 @@ exit $ret
%changelog
+* Mon Sep 27 2021 Remi Collet <remi@remirepo.net> - 4.2.3-1
+- update to 4.2.3
+- add dependency on php-symfony-polyfill
+
* Wed Aug 11 2021 Remi Collet <remi@remirepo.net> - 4.2.1-1
- update to 4.2.1