summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-15 08:29:56 +0200
committerRemi Collet <remi@php.net>2022-09-15 08:29:56 +0200
commit3754863a28d6af04471229fc68f8d0d14221780f (patch)
tree6307007f7415eb33b636371c4d9593622950e63c
parent7342ac598c2782b1e7f1d70640734beb62e182bb (diff)
update to 4.5.0
raise dependency on brick/math 0.8.8
-rw-r--r--composer.json16
-rw-r--r--php-ramsey-uuid.spec20
2 files changed, 21 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 30f8772..9653cad 100644
--- a/composer.json
+++ b/composer.json
@@ -12,7 +12,7 @@
"php": "^8.0",
"ext-ctype": "*",
"ext-json": "*",
- "brick/math": "^0.8 || ^0.9 || ^0.10",
+ "brick/math": "^0.8.8 || ^0.9 || ^0.10",
"ramsey/collection": "^1.0"
},
"require-dev": {
@@ -27,12 +27,13 @@
"php-mock/php-mock-mockery": "^1.3",
"php-parallel-lint/php-parallel-lint": "^1.1",
"phpbench/phpbench": "^1.0",
- "phpstan/extension-installer": "^1.0",
- "phpstan/phpstan": "^0.12",
- "phpstan/phpstan-mockery": "^0.12",
- "phpstan/phpstan-phpunit": "^0.12",
+ "phpstan/extension-installer": "^1.1",
+ "phpstan/phpstan": "^1.8",
+ "phpstan/phpstan-mockery": "^1.1",
+ "phpstan/phpstan-phpunit": "^1.1",
"phpunit/phpunit": "^8.5 || ^9",
- "slevomat/coding-standard": "^7.0",
+ "ramsey/composer-repl": "^1.4",
+ "slevomat/coding-standard": "^8.4",
"squizlabs/php_codesniffer": "^3.5",
"vimeo/psalm": "^4.9"
},
@@ -69,7 +70,8 @@
"captainhook/plugin-composer": true,
"ergebnis/composer-normalize": true,
"phpstan/extension-installer": true,
- "dealerdirect/phpcodesniffer-composer-installer": true
+ "dealerdirect/phpcodesniffer-composer-installer": true,
+ "ramsey/composer-repl": true
},
"sort-packages": true
},
diff --git a/php-ramsey-uuid.spec b/php-ramsey-uuid.spec
index ea648d7..ef735c9 100644
--- a/php-ramsey-uuid.spec
+++ b/php-ramsey-uuid.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-ramsey-uuid
#
-# Copyright (c) 2020-2021 Remi Collet
+# Copyright (c) 2020-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 373f7bacfcf3de038778ff27dcce5672ddbf4c8a
+%global gh_commit ef842484ba57f163c6d465ab744bfecb872a11d4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner ramsey
%global gh_project uuid
@@ -22,7 +22,7 @@
%global ns_project Uuid
Name: php-%{pk_vendor}-%{pk_name}
-Version: 4.4.0
+Version: 4.5.0
Release: 1%{?dist}
Summary: Library for generating and working with UUIDs
@@ -64,13 +64,13 @@ BuildRequires: php-spl
%if %{with tests}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(brick/math) >= 0.8 with php-composer(brick/math) < 1)
+BuildRequires: (php-composer(brick/math) >= 0.8.8 with php-composer(brick/math) < 1)
BuildRequires: (php-composer(ramsey/collection) >= 1.0 with php-composer(ramsey/collection) < 2)
BuildRequires: (php-composer(mockery/mockery) >= 1.3 with php-composer(mockery/mockery) < 2)
BuildRequires: (php-composer(php-mock/php-mock) >= 2.2 with php-composer(php-mock/php-mock) < 3)
# remirepo:6
%else
-BuildRequires: php-brick-math >= 0.8
+BuildRequires: php-brick-math >= 0.8.8
BuildRequires: php-ramsey-collection >= 1.0
BuildRequires: php-mockery >= 1.3
BuildRequires: php-mock2 >= 2.2
@@ -85,18 +85,18 @@ BuildRequires: php-fedora-autoloader-devel
# "php": "^8.0",
# "ext-ctype": "*",
# "ext-json": "*",
-# "brick/math": "^0.8 || ^0.9 || ^0.10",
+# "brick/math": "^0.8.8 || ^0.9 || ^0.10",
# "ramsey/collection": "^1.0",
Requires: php(language) >= 8.0
Requires: php-ctype
Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(brick/math) >= 0.8 with php-composer(brick/math) < 1)
+Requires: (php-composer(brick/math) >= 0.8.8 with php-composer(brick/math) < 1)
Requires: (php-composer(ramsey/collection) >= 1.0 with php-composer(ramsey/collection) < 2)
# remirepo:4
%else
-Requires: php-brick-math >= 0.8
+Requires: php-brick-math >= 0.8.8
Requires: php-ramsey-collection >= 1.0
%endif
# From phpcompatifo report for 4.1.1
@@ -191,6 +191,10 @@ exit $ret
%changelog
+* Thu Sep 15 2022 Remi Collet <remi@remirepo.net> - 4.5.0-1
+- update to 4.5.0
+- raise dependency on brick/math 0.8.8
+
* Mon Aug 8 2022 Remi Collet <remi@remirepo.net> - 4.4.0-1
- update to 4.4.0