summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-11 09:23:09 +0200
committerRemi Collet <remi@php.net>2021-10-11 09:23:09 +0200
commit456ede8af1463015935ac2856d9b4c06b2d3ff4e (patch)
tree8c10f9476d483a639eace1c92090691946e2145f
parent268b49eb75211d6ae5430c651d0e457d8e48b7a2 (diff)
update to 1.2.2
-rw-r--r--composer.json66
-rw-r--r--php-ramsey-collection.spec7
2 files changed, 35 insertions, 38 deletions
diff --git a/composer.json b/composer.json
index 73ec301..98862ee 100644
--- a/composer.json
+++ b/composer.json
@@ -61,48 +61,42 @@
},
"scripts": {
"post-autoload-dump": "captainhook install --ansi -f -s",
- "br:analyze": [
- "@br:analyze:phpstan",
- "@br:analyze:psalm"
+ "dev:analyze": [
+ "@dev:analyze:phpstan",
+ "@dev:analyze:psalm"
],
- "br:analyze:phpstan": "phpstan --memory-limit=1G analyse",
- "br:analyze:psalm": "psalm --diff --config=psalm.xml",
- "br:build:clean": "git clean -fX build/.",
- "br:build:clear-cache": "git clean -fX build/cache/.",
- "br:lint": "phpcs --cache=build/cache/phpcs.cache",
- "br:lint:fix": "./bin/lint-fix.sh",
- "br:repl": [
+ "dev:analyze:phpstan": "phpstan --memory-limit=1G analyse",
+ "dev:analyze:psalm": "psalm --diff --config=psalm.xml",
+ "dev:build:clean": "git clean -fX build/.",
+ "dev:build:clear-cache": "git clean -fX build/cache/.",
+ "dev:lint": "phpcs --cache=build/cache/phpcs.cache",
+ "dev:lint:fix": "./bin/lint-fix.sh",
+ "dev:repl": [
"echo ; echo 'Type ./bin/repl to start the REPL.'"
],
- "br:test": "phpunit",
- "br:test:all": [
- "@br:lint",
- "@br:analyze",
- "@br:test"
+ "dev:test": "phpunit",
+ "dev:test:all": [
+ "@dev:lint",
+ "@dev:analyze",
+ "@dev:test"
],
- "br:test:coverage:ci": "phpunit --coverage-clover build/logs/clover.xml",
- "br:test:coverage:html": "phpunit --coverage-html build/coverage",
- "pre-commit": [
- "@br:lint:fix",
- "@br:lint",
- "@br:analyze"
- ],
- "test": "@br:test:all"
+ "dev:test:coverage:ci": "phpunit --coverage-clover build/logs/clover.xml",
+ "dev:test:coverage:html": "phpunit --coverage-html build/coverage",
+ "test": "@dev:test:all"
},
"scripts-descriptions": {
- "br:analyze": "Performs static analysis on the code base.",
- "br:analyze:phpstan": "Runs the PHPStan static analyzer.",
- "br:analyze:psalm": "Runs the Psalm static analyzer.",
- "br:build:clean": "Removes everything not under version control from the build directory.",
- "br:build:clear-cache": "Removes everything not under version control from build/cache/.",
- "br:lint": "Checks all source code for coding standards issues.",
- "br:lint:fix": "Checks source code for coding standards issues and fixes them, if possible.",
- "br:repl": "Note: Use ./bin/repl to run the REPL.",
- "br:test": "Runs the full unit test suite.",
- "br:test:all": "Runs linting, static analysis, and unit tests.",
- "br:test:coverage:ci": "Runs the unit test suite and generates a Clover coverage report.",
- "br:test:coverage:html": "Runs the unit tests suite and generates an HTML coverage report.",
- "pre-commit": "These commands are run as part of a Git pre-commit hook installed using captainhook/captainhook. Each command should be prepared to accept a list of space-separated staged files.",
+ "dev:analyze": "Performs static analysis on the code base.",
+ "dev:analyze:phpstan": "Runs the PHPStan static analyzer.",
+ "dev:analyze:psalm": "Runs the Psalm static analyzer.",
+ "dev:build:clean": "Removes everything not under version control from the build directory.",
+ "dev:build:clear-cache": "Removes everything not under version control from build/cache/.",
+ "dev:lint": "Checks all source code for coding standards issues.",
+ "dev:lint:fix": "Checks source code for coding standards issues and fixes them, if possible.",
+ "dev:repl": "Note: Use ./bin/repl to run the REPL.",
+ "dev:test": "Runs the full unit test suite.",
+ "dev:test:all": "Runs linting, static analysis, and unit tests.",
+ "dev:test:coverage:ci": "Runs the unit test suite and generates a Clover coverage report.",
+ "dev:test:coverage:html": "Runs the unit tests suite and generates an HTML coverage report.",
"test": "Shortcut to run the full test suite."
}
}
diff --git a/php-ramsey-collection.spec b/php-ramsey-collection.spec
index cb69c5c..2cff320 100644
--- a/php-ramsey-collection.spec
+++ b/php-ramsey-collection.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit eaca1dc1054ddd10cbd83c1461907bee6fb528fa
+%global gh_commit cccc74ee5e328031b15640b51056ee8d3bb66c0a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner ramsey
%global gh_project collection
@@ -22,7 +22,7 @@
%global ns_project Collection
Name: php-%{pk_vendor}-%{pk_name}
-Version: 1.2.1
+Version: 1.2.2
Release: 1%{?dist}
Summary: Library for representing and manipulating collections
@@ -172,6 +172,9 @@ exit $ret
%changelog
+* Mon Oct 11 2021 Remi Collet <remi@remirepo.net> - 1.2.2-1
+- update to 1.2.2
+
* Fri Aug 6 2021 Remi Collet <remi@remirepo.net> - 1.2.1-1
- update to 1.2.1
- raise dependency on PHP 7.3