summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-ralouphie-getallheaders.spec11
1 files changed, 7 insertions, 4 deletions
diff --git a/php-ralouphie-getallheaders.spec b/php-ralouphie-getallheaders.spec
index d4c8708..e366830 100644
--- a/php-ralouphie-getallheaders.spec
+++ b/php-ralouphie-getallheaders.spec
@@ -28,7 +28,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 5%{?github_release}%{?dist}
Summary: A polyfill for getallheaders
License: MIT
@@ -44,7 +44,7 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: phpunit6
+BuildRequires: phpunit7
## phpcompatinfo for version 3.0.3
## <none>
%endif
@@ -87,8 +87,8 @@ ln -s %{buildroot}%{phpdir}/%{composer_vendor}-%{composer_project}/autoload.php
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit6)
-for PHP_EXEC in php php70 php71 php72 php73 php74; do
+PHPUNIT=$(which phpunit7)
+for PHP_EXEC in php php72 php73 php74 php80; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose || RETURN_CODE=1
fi
@@ -108,6 +108,9 @@ exit $RETURN_CODE
%changelog
+* Wed Mar 24 2021 Remi Collet <remi@remirepo.net> - 3.0.3-5
+- switch to phpunit7
+
* Mon Dec 16 2019 Shawn Iwinski <shawn@iwin.ski> - 3.0.3-1
- Update to 3.0.3
- Use PHPUnit 6