summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-26 10:12:04 +0200
committerRemi Collet <remi@remirepo.net>2017-06-26 10:12:04 +0200
commitd510451695196f16cfe0f31b01121ddc8e3b0432 (patch)
tree59db35f06461578d7b3b4e7a3a51a771feff1f26
parent950783d08fc7681b632b7f5aa3797aba898ac1bf (diff)
sync with Fedora
-rw-r--r--psysh.spec24
1 files changed, 13 insertions, 11 deletions
diff --git a/psysh.spec b/psysh.spec
index d3354a4..9087059 100644
--- a/psysh.spec
+++ b/psysh.spec
@@ -77,10 +77,9 @@ BuildRequires: php-composer(symfony/var-dumper) < %{symfony_max_ver}
BuildRequires: php-composer(symfony/var-dumper) >= %{symfony_min_ver}
## composer.json: optional
BuildRequires: php-pcntl
-BuildRequires: php-pdo_sqlite
BuildRequires: php-posix
BuildRequires: php-readline
-## phpcompatinfo (computed from version 0.8.3)
+## phpcompatinfo (computed from version 0.8.8)
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-dom
@@ -109,10 +108,9 @@ Requires: php-composer(symfony/var-dumper) < %{symfony_max_ver}
Requires: php-composer(symfony/var-dumper) >= %{symfony_min_ver}
# composer.json: optional
Requires: php-pcntl
-Requires: php-pdo_sqlite
Requires: php-posix
Requires: php-readline
-# phpcompatinfo (computed from version 0.8.3)
+# phpcompatinfo (computed from version 0.8.8)
Requires: php-ctype
Requires: php-date
Requires: php-json
@@ -161,14 +159,14 @@ require_once __DIR__.'/functions.php';
\Fedora\Autoloader\Dependencies::required(array(
'%{phpdir}/JakubOnderka/PhpConsoleHighlighter/autoload.php',
- [
+ array(
'%{phpdir}/Symfony3/Component/Console/autoload.php',
'%{phpdir}/Symfony/Component/Console/autoload.php',
- ],
- [
+ ),
+ array(
'%{phpdir}/Symfony3/Component/VarDumper/autoload.php',
'%{phpdir}/Symfony/Component/VarDumper/autoload.php',
- ],
+ ),
'%{phpdir}/XdgBaseDir/autoload.php',
array(
'%{phpdir}/PhpParser3/autoload.php',
@@ -214,9 +212,10 @@ rm test/Psy/Test/Readline/HoaConsoleTest.php
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72; do
- if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit --verbose --bootstrap bootstrap.php \
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in "" %{?rhel:php54 php55} php56 php70 php71; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done
@@ -236,6 +235,9 @@ exit $RETURN_CODE
%changelog
+* Sun Jun 25 2017 Shawn Iwinski <shawn@iwin.ski> - 0.8.8-1
+- Update to 0.8.8 (RHBZ #1464772)
+
* Sat Jun 24 2017 Remi Collet <remi@remirepo.net> - 0.8.8-1
- Update to 0.8.8