summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-05 06:57:20 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-05 06:57:20 +0100
commit7d40360d53a784bd6adc368360b55f67de072a8c (patch)
tree47693dc3c825b00e06e48c8e8f5527c92de3bf75
parent7ef2fbbd3573c047ee4a5eeb4112c73592eadc86 (diff)
psysh: sync with Fedora
-rw-r--r--psysh.spec70
1 files changed, 38 insertions, 32 deletions
diff --git a/psysh.spec b/psysh.spec
index 81668bf..4633f44 100644
--- a/psysh.spec
+++ b/psysh.spec
@@ -62,20 +62,26 @@ BuildArch: noarch
%if %{with_tests}
BuildRequires: php-cli
## composer.json
-BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-BuildRequires: php-composer(dnoegel/php-xdg-base-dir) >= %{php_xdg_base_dir_min_ver}
+BuildRequires: php-composer(dnoegel/php-xdg-base-dir) < %{php_xdg_base_dir_max_ver}
+BuildRequires: php-composer(dnoegel/php-xdg-base-dir) >= %{php_xdg_base_dir_min_ver}
+BuildRequires: php-composer(jakub-onderka/php-console-highlighter) < %{php_console_highlighter_max_ver}
BuildRequires: php-composer(jakub-onderka/php-console-highlighter) >= %{php_console_highlighter_min_ver}
-BuildRequires: php-composer(nikic/php-parser) >= %{php_parser_min_ver}
-BuildRequires: php-composer(symfony/console) >= %{symfony_min_ver}
-BuildRequires: php-composer(symfony/finder) >= %{symfony_min_ver}
-BuildRequires: php-composer(symfony/var-dumper) >= %{symfony_min_ver}
+BuildRequires: php-composer(nikic/php-parser) < %{php_parser_max_ver}
+BuildRequires: php-composer(nikic/php-parser) >= %{php_parser_min_ver}
+BuildRequires: php-composer(symfony/console) < %{symfony_max_ver}
+BuildRequires: php-composer(symfony/console) >= %{symfony_min_ver}
+BuildRequires: php-composer(symfony/finder) < %{symfony_max_ver}
+BuildRequires: php-composer(symfony/finder) >= %{symfony_min_ver}
+BuildRequires: php-composer(symfony/var-dumper) < %{symfony_max_ver}
+BuildRequires: php-composer(symfony/var-dumper) >= %{symfony_min_ver}
## composer.json: optional
BuildRequires: php-pcntl
BuildRequires: php-pdo_sqlite
BuildRequires: php-posix
BuildRequires: php-readline
-## phpcompatinfo (computed from version 0.8.0)
+## phpcompatinfo (computed from version 0.8.2)
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-dom
@@ -91,17 +97,17 @@ BuildRequires: php-composer(fedora/autoloader)
Requires: php-cli
# composer.json
-Requires: php(language) >= %{php_min_ver}
-Requires: php-composer(dnoegel/php-xdg-base-dir) < %{php_xdg_base_dir_max_ver}
-Requires: php-composer(dnoegel/php-xdg-base-dir) >= %{php_xdg_base_dir_min_ver}
+Requires: php(language) >= %{php_min_ver}
+Requires: php-composer(dnoegel/php-xdg-base-dir) < %{php_xdg_base_dir_max_ver}
+Requires: php-composer(dnoegel/php-xdg-base-dir) >= %{php_xdg_base_dir_min_ver}
Requires: php-composer(jakub-onderka/php-console-highlighter) < %{php_console_highlighter_max_ver}
Requires: php-composer(jakub-onderka/php-console-highlighter) >= %{php_console_highlighter_min_ver}
-Requires: php-composer(nikic/php-parser) < %{php_parser_max_ver}
-Requires: php-composer(nikic/php-parser) >= %{php_parser_min_ver}
-Requires: php-composer(symfony/console) < %{symfony_max_ver}
-Requires: php-composer(symfony/console) >= %{symfony_min_ver}
-Requires: php-composer(symfony/var-dumper) < %{symfony_max_ver}
-Requires: php-composer(symfony/var-dumper) >= %{symfony_min_ver}
+Requires: php-composer(nikic/php-parser) < %{php_parser_max_ver}
+Requires: php-composer(nikic/php-parser) >= %{php_parser_min_ver}
+Requires: php-composer(symfony/console) < %{symfony_max_ver}
+Requires: php-composer(symfony/console) >= %{symfony_min_ver}
+Requires: php-composer(symfony/var-dumper) < %{symfony_max_ver}
+Requires: php-composer(symfony/var-dumper) >= %{symfony_min_ver}
# composer.json: optional
Requires: php-pcntl
Requires: php-pdo_sqlite
@@ -189,6 +195,8 @@ BOOTSTRAP
: Skip tests known to fail
sed '/exit\(\).*die;/d' -i test/Psy/Test/CodeCleaner/ImplicitReturnPassTest.php
sed '/foo.*return/d' -i test/Psy/Test/CodeCleanerTest.php
+sed 's/function testFilesAndDirectories/function SKIP_testFilesAndDirectories/' \
+ -i test/Psy/Test/ConfigurationTest.php
: Skip tests known to fail in a mock env
sed 's/function testFormat/function SKIP_testFormat/' \
@@ -199,23 +207,17 @@ sed 's/function testWriteReturnValue/function SKIP_testWriteReturnValue/' \
: Drop unneeded test as readline is always there
rm test/Psy/Test/Readline/HoaConsoleTest.php
-: Run upstream test suite
-# remirepo:11
-run=0
-ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --bootstrap bootstrap.php || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit --bootstrap bootstrap.php || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
+: Upstream tests
%{_bindir}/phpunit --verbose --bootstrap bootstrap.php
-# remirepo:2
-fi
-exit $ret
+
+: Upstream tests with SCLs if available
+SCL_RETURN_CODE=0
+for SCL in %{?rhel:php54 php55} php56 php70 php71; do
+ if which $SCL; then
+ $SCL %{_bindir}/phpunit --verbose --bootstrap bootstrap.php || SCL_RETURN_CODE=1
+ fi
+done
+exit $SCL_RETURN_CODE
%else
: Tests skipped
%endif
@@ -236,6 +238,10 @@ rm -rf %{buildroot}
%changelog
+* Sat Mar 04 2017 2017 Shawn Iwinski <shawn@iwin.ski> - 0.8.2-1
+- Update to 0.8.2 (RHBZ #1413429)
+- Test with SCLs if available
+
* Wed Mar 1 2017 Remi Collet <remi@remirepo.net> - 0.8.2-1
- update to 0.8.2