summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShawn Iwinski <shawn@iwin.ski>2017-04-08 17:35:49 -0400
committerRemi Collet <remi@remirepo.net>2017-04-10 09:04:00 +0200
commit555a301225c00935b0206d295d15b1b05292b625 (patch)
tree4cc894e96f9f87bc889d198113febe3ca299e4f1
parentc04c10d6cc50c8e7de39f02664a0714802d1305b (diff)
Update to 0.8.3 (RHBZ #1433813)
- Allow Symfony 3 (cherry picked from commit f91c135cb3e485c802410127437b72ba50615cc9)
-rw-r--r--.gitignore3
-rw-r--r--psysh.spec46
2 files changed, 27 insertions, 22 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..3bf9245
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/psysh-0.7.2-e64e10b20f8d229cac76399e1f3edddb57a0f280.tar.gz
+/psysh-0.8.0-4a8860e13aa68a4bbf2476c014f8a1f14f1bf991.tar.gz
+/psysh-0.8.2-97113db4107a4126bef933b60fea6dbc9f615d41.tar.gz
diff --git a/psysh.spec b/psysh.spec
index 9e8f643..3c51f46 100644
--- a/psysh.spec
+++ b/psysh.spec
@@ -36,7 +36,7 @@
# "symfony/var-dumper": "~2.7|~3.0"
# NOTE: Min version not 2.7.0 because autoloader required
%global symfony_min_ver 2.7.1
-%global symfony_max_ver 3.0
+%global symfony_max_ver 4.0
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -45,7 +45,7 @@
Name: psysh
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 2%{?github_release}%{?dist}
Summary: A runtime developer console, interactive debugger and REPL for PHP
Group: Development/Libraries
@@ -56,7 +56,6 @@ Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{githu
# Update bin script to use generated autoloader
Patch0: %{name}-bin-autoload.patch
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -81,7 +80,7 @@ BuildRequires: php-pcntl
BuildRequires: php-pdo_sqlite
BuildRequires: php-posix
BuildRequires: php-readline
-## phpcompatinfo (computed from version 0.8.2)
+## phpcompatinfo (computed from version 0.8.3)
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-dom
@@ -113,7 +112,7 @@ Requires: php-pcntl
Requires: php-pdo_sqlite
Requires: php-posix
Requires: php-readline
-# phpcompatinfo (computed from version 0.8.0)
+# phpcompatinfo (computed from version 0.8.3)
Requires: php-ctype
Requires: php-date
Requires: php-json
@@ -133,6 +132,8 @@ Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
%description
%{summary}.
+Autoloader: %{phpdir}/Psy/autoload.php
+
%prep
%setup -qn %{github_name}-%{github_commit}
@@ -160,8 +161,14 @@ require_once __DIR__.'/functions.php';
\Fedora\Autoloader\Dependencies::required(array(
'%{phpdir}/JakubOnderka/PhpConsoleHighlighter/autoload.php',
- '%{phpdir}/Symfony/Component/Console/autoload.php',
- '%{phpdir}/Symfony/Component/VarDumper/autoload.php',
+ [
+ '%{phpdir}/Symfony3/Component/Console/autoload.php',
+ '%{phpdir}/Symfony/Component/Console/autoload.php',
+ ],
+ [
+ '%{phpdir}/Symfony3/Component/VarDumper/autoload.php',
+ '%{phpdir}/Symfony/Component/VarDumper/autoload.php',
+ ],
'%{phpdir}/XdgBaseDir/autoload.php',
array(
'%{phpdir}/PhpParser3/autoload.php',
@@ -172,8 +179,6 @@ AUTOLOAD
%install
-rm -rf %{buildroot}
-
: Library
mkdir -p %{buildroot}%{phpdir}
cp -rp src/* %{buildroot}%{phpdir}/
@@ -208,27 +213,20 @@ sed 's/function testWriteReturnValue/function SKIP_testWriteReturnValue/' \
rm test/Psy/Test/Readline/HoaConsoleTest.php
: Upstream tests
-%{_bindir}/phpunit --verbose --bootstrap bootstrap.php
-
-: Upstream tests with SCLs if available
-SCL_RETURN_CODE=0
-for SCL in %{?rhel:php54 php55} php56 php70 php71; do
- if which $SCL; then
- $SCL %{_bindir}/phpunit --verbose --bootstrap bootstrap.php || SCL_RETURN_CODE=1
+RETURN_CODE=0
+for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71; do
+ if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC %{_bindir}/phpunit --verbose --bootstrap bootstrap.php \
+ || RETURN_CODE=1
fi
done
-exit $SCL_RETURN_CODE
+exit $RETURN_CODE
%else
: Tests skipped
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -238,6 +236,10 @@ rm -rf %{buildroot}
%changelog
+* Sat Apr 08 2017 2017 Shawn Iwinski <shawn@iwin.ski> - 0.8.3-1
+- Update to 0.8.3 (RHBZ #1433813)
+- Allow Symfony 3
+
* Mon Mar 20 2017 Remi Collet <remi@remirepo.net> - 0.8.3-1
- Update to 0.8.3