summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-14 10:52:01 +0200
committerRemi Collet <remi@remirepo.net>2021-04-14 10:52:01 +0200
commitf0f70e6bafa59579eebc9f716fbb55bd29dbd5c1 (patch)
tree7952232119932841d5ca3c61d64a2b549146498f
parent4736ca762b3456574e5bc689e604448a7545862f (diff)
update to 1.1.1HEADmaster
raise dependency on PHP 8.0
-rw-r--r--composer.json27
-rw-r--r--php-psr-link.spec16
2 files changed, 37 insertions, 6 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..529fb56
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,27 @@
+{
+ "name": "psr/link",
+ "type": "library",
+ "homepage": "https://github.com/php-fig/link",
+ "description": "Common interfaces for HTTP links",
+ "keywords": ["psr", "psr-13", "http", "http-link", "link", "rest"],
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "PHP-FIG",
+ "homepage": "http://www.php-fig.org/"
+ }
+ ],
+ "require": {
+ "php": ">=8.0.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Psr\\Link\\": "src/"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.0.x-dev"
+ }
+ }
+}
diff --git a/php-psr-link.spec b/php-psr-link.spec
index 0f992e1..5ee1549 100644
--- a/php-psr-link.spec
+++ b/php-psr-link.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-psr-link
#
-# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2021 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,14 +12,14 @@
%global github_owner php-fig
%global github_name link
-%global github_version 1.0.0
-%global github_commit eea8e8662d5cd3ae4517c9b864493f59fca95562
+%global github_version 1.1.1
+%global github_commit 846c25f58a1f02b93a00f2404e3626b6bf9b7807
%global composer_vendor psr
%global composer_project link
-# "php": ">=5.3.0"
-%global php_min_ver 5.3.0
+# "php": ">=8.0.0"
+%global php_min_ver 8.0.0
%{!?phpdir: %global phpdir %{_datadir}/php}
@@ -28,7 +28,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: Common interfaces for HTTP links (PSR-13)
-Group: Development/Libraries
License: MIT
URL: http://www.php-fig.org/psr/psr-13/
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -92,6 +91,7 @@ cp -rp src %{buildroot}%{phpdir}/Psr/Link
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE.md
%doc README.md
@@ -101,5 +101,9 @@ cp -rp src %{buildroot}%{phpdir}/Psr/Link
%changelog
+* Wed Apr 14 2021 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+- raise dependency on PHP 8.0
+
* Sun Jun 11 2017 Shawn Iwinski <shawn@iwin.ski> - 1.0.0-1
- Initial package