summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-13 09:11:24 +0100
committerRemi Collet <remi@remirepo.net>2018-12-13 09:11:24 +0100
commit9765ffc8828289af2d3ad70afded383e47156038 (patch)
treeffb06e4c0e80b528fb8ade3437817d4681d2eb85
new package
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json35
-rw-r--r--php-psr-http-factory.spec111
4 files changed, 158 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..af62b29
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,35 @@
+{
+ "name": "psr/http-factory",
+ "description": "Common interfaces for PSR-7 HTTP message factories",
+ "keywords": [
+ "psr",
+ "psr-7",
+ "psr-17",
+ "http",
+ "factory",
+ "message",
+ "request",
+ "response"
+ ],
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "PHP-FIG",
+ "homepage": "http://www.php-fig.org/"
+ }
+ ],
+ "require": {
+ "php": ">=7.0.0",
+ "psr/http-message": "^1.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Psr\\Http\\Message\\": "src/"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.0.x-dev"
+ }
+ }
+}
diff --git a/php-psr-http-factory.spec b/php-psr-http-factory.spec
new file mode 100644
index 0000000..919eca2
--- /dev/null
+++ b/php-psr-http-factory.spec
@@ -0,0 +1,111 @@
+# remirepo/fedora spec file for php-psr-http-factory
+#
+# Copyright (c) 2018 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%global gh_commit 378bfe27931ecc54ff824a20d6f6bfc303bbd04c
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner php-fig
+%global gh_project http-factory
+
+%global pk_vendor psr
+%global pk_project %{gh_project}
+
+Name: php-%{pk_vendor}-%{pk_project}
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Common interfaces for PSR-7 HTTP message factories
+
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{url}/archive/%{gh_commit}/%{name}-%{version}-%{gh_commit}.tar.gz
+
+BuildArch: noarch
+# For tests
+BuildRequires: php(language) >= 7
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
+# remirepo:3
+%else
+BuildRequires: php-psr-http-message
+%endif
+BuildRequires: php-cli
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer.json, "require": {
+# "php": ">=7.0.0",
+# "psr/http-message": "^1.0"
+Requires: php(language) >= 7
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
+# remirepo:3
+%else
+Requires: php-psr-http-message
+%endif
+# phpcompatinfo (computed from version 1.0.0)
+# <none>
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+This package holds all interfaces related to
+PSR-17 (HTTP Message Factories).
+
+Please refer to the specification for a description:
+https://www.php-fig.org/psr/psr-17/
+
+
+Autoloader: %{_datadir}/php/Psr/Http/Message/%{pk_project}-autoload.php
+
+
+%prep
+%setup -qn %{gh_project}-%{gh_commit}
+
+
+%build
+: Generate autoloader
+%{_bindir}/phpab --template fedora --output src/%{pk_project}-autoload.php src
+
+cat << 'EOF' | tee -a src/%{pk_project}-autoload.php
+\Fedora\Autoloader\Dependencies::required(array(
+ '%{_datadir}/php/Psr/Http/Message/autoload.php',
+));
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{_datadir}/php/Psr/Http
+cp -rp src %{buildroot}%{_datadir}/php/Psr/Http/Message
+
+
+%check
+: Test autoloader
+php -nr '
+require "%{buildroot}%{_datadir}/php/Psr/Http/Message/%{pk_project}-autoload.php";
+exit (interface_exists("Psr\\Http\\Message\\RequestFactoryInterface") ? 0 : 1);
+'
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{_datadir}/php/Psr/Http/Message/*php
+
+
+%changelog
+* Thu Dec 13 2018 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- Initial package, version 1.0.0
+