summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-08-20 08:22:46 +0200
committerRemi Collet <remi@remirepo.net>2018-08-20 08:22:46 +0200
commit0b8f17798be222eca8f7efd8968a42b7c7b708a3 (patch)
tree9335796aebd3110391664dc259130456911ee4fe
parent9b86ff4d11233288ed2440d1b48b51764d9d43e6 (diff)
update to 3.0.2 (no change)
-rw-r--r--composer.json2
-rw-r--r--php-pragmarx-google2fa.spec13
2 files changed, 9 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index a8df986..7371a23 100644
--- a/composer.json
+++ b/composer.json
@@ -13,7 +13,7 @@
"require": {
"php": ">=5.4",
"paragonie/constant_time_encoding": "~1.0|~2.0",
- "paragonie/random_compat": "~1.4|~2.0",
+ "paragonie/random_compat": ">=1 <9.99",
"symfony/polyfill-php56": "~1.2"
},
"require-dev": {
diff --git a/php-pragmarx-google2fa.spec b/php-pragmarx-google2fa.spec
index bc043f3..63a9e10 100644
--- a/php-pragmarx-google2fa.spec
+++ b/php-pragmarx-google2fa.spec
@@ -9,7 +9,7 @@
%global with_tests 0%{!?_without_tests:1}
# Github
-%global gh_commit 40b3ce025bed0f9cd0c1c8ab7fc8265344c73de0
+%global gh_commit d9d960370277958c700552c551e136018b915499
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner antonioribeiro
%global gh_project google2fa
@@ -21,8 +21,8 @@
%global ns_project Google2FA
Name: php-%{pk_vendor}-%{pk_project}
-Version: 3.0.1
-Release: 2%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
+Version: 3.0.2
+Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Google Two-Factor Authentication for PHP Package
License: MIT
@@ -58,7 +58,7 @@ BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": ">=5.4",
# "paragonie/constant_time_encoding": "~1.0|~2.0",
-# "paragonie/random_compat": "~1.4|~2.0",
+# "paragonie/random_compat": ">=1 <9.9",
# "symfony/polyfill-php56": "~1.2"
# Use 5.6 and avoid polyfill
Requires: php(language) >= 5.6
@@ -136,7 +136,7 @@ EOF
# TODO investigate test_qrcode_inline failing with php < 7.2 (both images seems ok)
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
if [ $($cmd -r 'echo PHP_VERSION_ID;') -lt 70200 ]; then
$cmd %{_bindir}/phpunit --no-coverage --verbose --filter '^((?!(testQrcodeInline)).)*$' || ret=1
@@ -161,6 +161,9 @@ exit $ret
%changelog
+* Mon Aug 20 2018 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2 (no change)
+
* Wed May 2 2018 Remi Collet <remi@remirepo.net> - 3.0.1-2
- allow paragonie/constant_time_encoding v2