summaryrefslogtreecommitdiffstats
path: root/php-phpunitgoodpractices-polyfill.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunitgoodpractices-polyfill.spec')
-rw-r--r--php-phpunitgoodpractices-polyfill.spec23
1 files changed, 15 insertions, 8 deletions
diff --git a/php-phpunitgoodpractices-polyfill.spec b/php-phpunitgoodpractices-polyfill.spec
index 5ca0279..c2416db 100644
--- a/php-phpunitgoodpractices-polyfill.spec
+++ b/php-phpunitgoodpractices-polyfill.spec
@@ -7,8 +7,9 @@
# Please, preserve the changelog entries
#
-# Github
-%global gh_commit f7c9b779e5c14ad37d27b108f2a370bb3c0312e8
+# Polyfill
+# https://github.com/PHPUnitGoodPractices/polyfill/releases
+%global gh_commit 1613c59be473c6b238c119607de820b9274c81fd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner PHPUnitGoodPractices
%global gh_project polyfill
@@ -21,16 +22,16 @@
%global php_home %{_datadir}/php
%global with_tests 0%{!?_without_tests:1}
# Traits
-%global tr_commit d7864f7d8eb9ee2e84eebc45baf3eace73ce2c4b
+# https://github.com/PHPUnitGoodPractices/Traits/releases
+%global tr_commit 7bdb460da0f9d4cfa2f11ca1ecb69a6d7f126925
%global tr_short %(c=%{tr_commit}; echo ${c:0:7})
-%global tr_version 1.7.0
+%global tr_version 1.8.0
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.1.0
-Release: 5%{?dist}
+Version: 1.2.0
+Release: 1%{?dist}
Summary: Lacking future-compat polyfills for PHPUnit
-Group: Development/Tools
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
# git snapshot to get upstream test suite (none for now)
@@ -55,7 +56,7 @@ BuildRequires: php-fedora-autoloader-devel
Requires: php(language) >= 5.5
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (phpunit7 or phpunit6 or php-phpunit-PHPUnit)
+Requires: (phpunit8 or phpunit7 or phpunit6 or php-phpunit-PHPUnit)
# remirepo:3
%else
Requires: php-phpunit-PHPUnit
@@ -93,6 +94,7 @@ require_once '%{php_home}/Fedora/Autoloader/autoload.php';
if (!class_exists('PHPUnit\\Framework\\TestCase')) { // Call outside of phpunit command
\Fedora\Autoloader\Dependencies::required([
[
+ '%{php_home}/PHPUnit8/autoload.php',
'%{php_home}/PHPUnit7/autoload.php',
'%{php_home}/PHPUnit6/autoload.php',
'%{php_home}/PHPUnit/Autoload.php',
@@ -146,6 +148,11 @@ if (!class_exists("PHPUnitGoodPractices\\Traits\\PHPUnitVersionRetriever")) {
%changelog
+* Tue Mar 26 2019 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update phpunitgoodpractices/polyfill to 1.2.0
+- update phpunitgoodpractices/traits to 1.8.0
+- allow PHPUnit 8
+
* Sat Dec 29 2018 Remi Collet <remi@remirepo.net> - 1.1.0-5
- update phpunitgoodpractices/traits to 1.7.0