summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-08 08:04:31 +0100
committerRemi Collet <remi@remirepo.net>2020-12-08 08:04:31 +0100
commit7dd0c45d0607dfc03af0265f251b96a8b8cbe296 (patch)
treed95097d6bcdadc843284d68fa9e6e6162445c966
parent3e7253dc509e88e1ad75f91f3569b1907f413e1f (diff)
update phpunitgoodpractices/polyfill to 1.5.0HEADmaster
-rw-r--r--composer-polyfill.json6
-rw-r--r--php-phpunitgoodpractices-polyfill.spec10
2 files changed, 9 insertions, 7 deletions
diff --git a/composer-polyfill.json b/composer-polyfill.json
index 7a25985..10433c0 100644
--- a/composer-polyfill.json
+++ b/composer-polyfill.json
@@ -14,10 +14,8 @@
"phpunit/phpunit": "^4.8.36 || ^5.7.27 || ^6.5.14 || ^7.5.20 || ^8.0 || ^9.0"
},
"require-dev": {
- "friendsofphp/php-cs-fixer": "^2.16"
- },
- "conflict": {
- "hhvm": "*"
+ "friendsofphp/php-cs-fixer": "^2",
+ "php-coveralls/php-coveralls": "^2.4"
},
"config": {
"optimize-autoloader": true,
diff --git a/php-phpunitgoodpractices-polyfill.spec b/php-phpunitgoodpractices-polyfill.spec
index 4b53758..8fb2df9 100644
--- a/php-phpunitgoodpractices-polyfill.spec
+++ b/php-phpunitgoodpractices-polyfill.spec
@@ -9,7 +9,7 @@
# Polyfill
# https://github.com/PHPUnitGoodPractices/polyfill/releases
-%global gh_commit 0e3754f1e31b0051eeb5a7223f9b45ba6442af0d
+%global gh_commit b87c59f0d3df764d0dcf8154e18be69fe6cb5cba
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner PHPUnitGoodPractices
%global gh_project polyfill
@@ -28,7 +28,7 @@
%global tr_version 1.9.1
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.4.0
+Version: 1.5.0
Release: 1%{?dist}
Summary: Lacking future-compat polyfills for PHPUnit
@@ -45,7 +45,8 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.5
BuildRequires: %{_bindir}/phpunit
# From composer.json, "require-dev": {
-# "friendsofphp/php-cs-fixer": "^2.11"
+# "friendsofphp/php-cs-fixer": "^2",
+# "php-coveralls/php-coveralls": "^2.4"
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
@@ -147,6 +148,9 @@ if (!class_exists("PHPUnitGoodPractices\\Traits\\PHPUnitVersionRetriever")) {
%changelog
+* Tue Dec 8 2020 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update phpunitgoodpractices/polyfill to 1.5.0
+
* Tue Oct 20 2020 Remi Collet <remi@remirepo.net> - 1.4.0-1
- update phpunitgoodpractices/polyfill to 1.4.0
- update phpunitgoodpractices/traits to 1.9.1