summaryrefslogtreecommitdiffstats
path: root/makesrc.sh
diff options
context:
space:
mode:
Diffstat (limited to 'makesrc.sh')
-rwxr-xr-xmakesrc.sh4
1 files changed, 3 insertions, 1 deletions
diff --git a/makesrc.sh b/makesrc.sh
index 2b84cb1..45fea74 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -8,6 +8,8 @@ VERSION=$(sed -n '/^%global upstream_version/{s/.* //;p}' $NAME.spec)
COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
SHORT=${COMMIT:0:7}
+DATE=$(date -d "$DATE -4 days" +%Y-%m-%d)
+
if [ -f $NAME-$VERSION-$SHORT.tgz ]; then
echo "$NAME-$VERSION-$SHORT.tgz already there"
else
@@ -15,7 +17,7 @@ else
echo "Cloning..."
rm -rf $PROJECT-$COMMIT
- git clone --jobs 8 https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1
+ git clone --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1
echo "Getting commit..."
pushd $PROJECT-$COMMIT