summaryrefslogtreecommitdiffstats
path: root/phpunit9.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-01 15:55:40 +0200
committerRemi Collet <remi@php.net>2022-09-01 15:55:40 +0200
commitd49fa0c502cd3eb4a30b4865fd8a7fd9e336ca89 (patch)
tree8fccad5366d4ba487ca2b99eae379ab242dc2f7f /phpunit9.spec
parentab2fdb84742a99934d1b8730bff608261286d921 (diff)
update to 9.5.24
raise dependency on sebastian/type 3.1
Diffstat (limited to 'phpunit9.spec')
-rw-r--r--phpunit9.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/phpunit9.spec b/phpunit9.spec
index 82e16b5..3dc1e93 100644
--- a/phpunit9.spec
+++ b/phpunit9.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 888556852e7e9bbeeedb9656afe46118765ade34
+%global gh_commit d0aa6097bef9fd42458a9b3c49da32c6ce6129c5
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -25,7 +25,7 @@
%global ver_major 9
%global ver_minor 5
-%global upstream_version 9.5.23
+%global upstream_version 9.5.24
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -64,7 +64,7 @@ BuildRequires: (php-composer(sebastian/exporter) >= 4.0.2 with php-c
BuildRequires: (php-composer(sebastian/global-state) >= 5.0 with php-composer(sebastian/global-state) < 6)
BuildRequires: (php-composer(sebastian/object-enumerator) >= 4.0.2 with php-composer(sebastian/object-enumerator) < 5)
BuildRequires: (php-composer(sebastian/resource-operations) >= 3.0.2 with php-composer(sebastian/resource-operations) < 4)
-BuildRequires: (php-composer(sebastian/type) >= 3.0 with php-composer(sebastian/type) < 4)
+BuildRequires: (php-composer(sebastian/type) >= 3.1 with php-composer(sebastian/type) < 4)
BuildRequires: (php-composer(sebastian/version) >= 3.0.1 with php-composer(sebastian/version) < 4)
# remirepo:23
%else
@@ -87,7 +87,7 @@ BuildRequires: php-sebastian-exporter4 >= 4.0.2
BuildRequires: php-sebastian-global-state5 >= 5.0
BuildRequires: php-sebastian-object-enumerator4 >= 4.0.2
BuildRequires: php-sebastian-resource-operations3 >= 3.0.2
-BuildRequires: php-sebastian-type3 >= 3.0
+BuildRequires: php-sebastian-type3 >= 3.1
BuildRequires: php-sebastian-version3 >= 3.0.1
%endif
BuildRequires: php-dom
@@ -125,7 +125,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "sebastian/global-state": "^5.0.1",
# "sebastian/object-enumerator": "^4.0.3",
# "sebastian/resource-operations": "^3.0.3",
-# "sebastian/type": "^3.0",
+# "sebastian/type": "^3.1",
# "sebastian/version": "^3.0.2"
Requires: php(language) >= 7.3
Requires: php-cli
@@ -156,7 +156,7 @@ Requires: (php-composer(sebastian/exporter) >= 4.0.2 with php-c
Requires: (php-composer(sebastian/global-state) >= 5.0 with php-composer(sebastian/global-state) < 6)
Requires: (php-composer(sebastian/object-enumerator) >= 4.0.2 with php-composer(sebastian/object-enumerator) < 5)
Requires: (php-composer(sebastian/resource-operations) >= 3.0.2 with php-composer(sebastian/resource-operations) < 4)
-Requires: (php-composer(sebastian/type) >= 3.0 with php-composer(sebastian/type) < 4)
+Requires: (php-composer(sebastian/type) >= 3.1 with php-composer(sebastian/type) < 4)
Requires: (php-composer(sebastian/version) >= 3.0.1 with php-composer(sebastian/version) < 4)
# From composer.json, "suggest": {
# "ext-soap": "*",
@@ -184,7 +184,7 @@ Requires: php-sebastian-exporter4 >= 4.0.2
Requires: php-sebastian-global-state5 >= 5.0
Requires: php-sebastian-object-enumerator4 >= 4.0.2
Requires: php-sebastian-resource-operations3 >= 3.0.2
-Requires: php-sebastian-type3 >= 3.0
+Requires: php-sebastian-type3 >= 3.1
Requires: php-sebastian-version3 >= 3.0.1
%endif
# Autoloader
@@ -298,6 +298,10 @@ exit $ret
%changelog
+* Thu Sep 1 2022 Remi Collet <remi@remirepo.net> - 9.5.24-1
+- update to 9.5.24
+- raise dependency on sebastian/type 3.1
+
* Tue Aug 30 2022 Remi Collet <remi@remirepo.net> - 9.5.23-1
- update to 9.5.23
- keep dependency on phpspec/prophecy (optional)