summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-25 08:01:05 +0200
committerRemi Collet <remi@php.net>2022-09-25 08:01:05 +0200
commitb508812c3f9af4e0d0537539eeda0bbc34e5cdf3 (patch)
treea8675e314846e59c40c54da40ca4bc6b10daddb6
parentd49fa0c502cd3eb4a30b4865fd8a7fd9e336ca89 (diff)
update to 9.5.25
raise dependency on sebastian/comparator 4.0.8 raise dependency on sebastian/exporter 4.0.5 raise dependency on sebastian/type 3.2
-rw-r--r--composer.json6
-rw-r--r--phpunit9.spec40
2 files changed, 26 insertions, 20 deletions
diff --git a/composer.json b/composer.json
index 1e8cf96..be0af53 100644
--- a/composer.json
+++ b/composer.json
@@ -39,14 +39,14 @@
"phpunit/php-timer": "^5.0.2",
"sebastian/cli-parser": "^1.0.1",
"sebastian/code-unit": "^1.0.6",
- "sebastian/comparator": "^4.0.5",
+ "sebastian/comparator": "^4.0.8",
"sebastian/diff": "^4.0.3",
"sebastian/environment": "^5.1.3",
- "sebastian/exporter": "^4.0.3",
+ "sebastian/exporter": "^4.0.5",
"sebastian/global-state": "^5.0.1",
"sebastian/object-enumerator": "^4.0.3",
"sebastian/resource-operations": "^3.0.3",
- "sebastian/type": "^3.1",
+ "sebastian/type": "^3.2",
"sebastian/version": "^3.0.2"
},
"config": {
diff --git a/phpunit9.spec b/phpunit9.spec
index 3dc1e93..451e58d 100644
--- a/phpunit9.spec
+++ b/phpunit9.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit d0aa6097bef9fd42458a9b3c49da32c6ce6129c5
+%global gh_commit 3e6f90ca7e3d02025b1d147bd8d4a89fd4ca8a1d
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -25,7 +25,7 @@
%global ver_major 9
%global ver_minor 5
-%global upstream_version 9.5.24
+%global upstream_version 9.5.25
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -57,14 +57,14 @@ BuildRequires: (php-composer(phpunit/php-text-template) >= 2.0.2 with php-c
BuildRequires: (php-composer(phpunit/php-timer) >= 5.0.1 with php-composer(phpunit/php-timer) < 6)
BuildRequires: (php-composer(sebastian/cli-parser) >= 1.0 with php-composer(sebastian/cli-parser) < 2)
BuildRequires: (php-composer(sebastian/code-unit) >= 1.0.5 with php-composer(sebastian/code-unit) < 2)
-BuildRequires: (php-composer(sebastian/comparator) >= 4.0.5 with php-composer(sebastian/comparator) < 5)
+BuildRequires: (php-composer(sebastian/comparator) >= 4.0.8 with php-composer(sebastian/comparator) < 5)
BuildRequires: (php-composer(sebastian/diff) >= 4.0.2 with php-composer(sebastian/diff) < 5)
BuildRequires: (php-composer(sebastian/environment) >= 5.1.2 with php-composer(sebastian/environment) < 6)
-BuildRequires: (php-composer(sebastian/exporter) >= 4.0.2 with php-composer(sebastian/exporter) < 5)
+BuildRequires: (php-composer(sebastian/exporter) >= 4.0.5 with php-composer(sebastian/exporter) < 5)
BuildRequires: (php-composer(sebastian/global-state) >= 5.0 with php-composer(sebastian/global-state) < 6)
BuildRequires: (php-composer(sebastian/object-enumerator) >= 4.0.2 with php-composer(sebastian/object-enumerator) < 5)
BuildRequires: (php-composer(sebastian/resource-operations) >= 3.0.2 with php-composer(sebastian/resource-operations) < 4)
-BuildRequires: (php-composer(sebastian/type) >= 3.1 with php-composer(sebastian/type) < 4)
+BuildRequires: (php-composer(sebastian/type) >= 3.2 with php-composer(sebastian/type) < 4)
BuildRequires: (php-composer(sebastian/version) >= 3.0.1 with php-composer(sebastian/version) < 4)
# remirepo:23
%else
@@ -80,14 +80,14 @@ BuildRequires: php-phpunit-php-text-template2 >= 2.0.2
BuildRequires: php-phpunit-php-timer5 >= 5.0.1
BuildRequires: php-sebastian-cli-parser >= 1.0
BuildRequires: php-sebastian-code-unit >= 1.0.5
-BuildRequires: php-sebastian-comparator4 >= 4.0.5
+BuildRequires: php-sebastian-comparator4 >= 4.0.8
BuildRequires: php-sebastian-diff4 >= 4.0.2
BuildRequires: php-sebastian-environment5 >= 5.1.2
-BuildRequires: php-sebastian-exporter4 >= 4.0.2
+BuildRequires: php-sebastian-exporter4 >= 4.0.5
BuildRequires: php-sebastian-global-state5 >= 5.0
BuildRequires: php-sebastian-object-enumerator4 >= 4.0.2
BuildRequires: php-sebastian-resource-operations3 >= 3.0.2
-BuildRequires: php-sebastian-type3 >= 3.1
+BuildRequires: php-sebastian-type3 >= 3.2
BuildRequires: php-sebastian-version3 >= 3.0.1
%endif
BuildRequires: php-dom
@@ -118,14 +118,14 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "phpunit/php-timer": "^5.0.2",
# "sebastian/cli-parser": "^1.0.1",
# "sebastian/code-unit": "^1.0.6",
-# "sebastian/comparator": "^4.0.5",
+# "sebastian/comparator": "^4.0.8",
# "sebastian/diff": "^4.0.3",
# "sebastian/environment": "^5.1.3",
-# "sebastian/exporter": "^4.0.3",
+# "sebastian/exporter": "^4.0.5",
# "sebastian/global-state": "^5.0.1",
# "sebastian/object-enumerator": "^4.0.3",
# "sebastian/resource-operations": "^3.0.3",
-# "sebastian/type": "^3.1",
+# "sebastian/type": "^3.2",
# "sebastian/version": "^3.0.2"
Requires: php(language) >= 7.3
Requires: php-cli
@@ -149,14 +149,14 @@ Requires: (php-composer(phpunit/php-text-template) >= 2.0.2 with php-c
Requires: (php-composer(phpunit/php-timer) >= 5.0.1 with php-composer(phpunit/php-timer) < 6)
Requires: (php-composer(sebastian/cli-parser) >= 1.0 with php-composer(sebastian/cli-parser) < 2)
Requires: (php-composer(sebastian/code-unit) >= 1.0.5 with php-composer(sebastian/code-unit) < 2)
-Requires: (php-composer(sebastian/comparator) >= 4.0.5 with php-composer(sebastian/comparator) < 5)
+Requires: (php-composer(sebastian/comparator) >= 4.0.8 with php-composer(sebastian/comparator) < 5)
Requires: (php-composer(sebastian/diff) >= 4.0.2 with php-composer(sebastian/diff) < 5)
Requires: (php-composer(sebastian/environment) >= 5.1.2 with php-composer(sebastian/environment) < 6)
-Requires: (php-composer(sebastian/exporter) >= 4.0.2 with php-composer(sebastian/exporter) < 5)
+Requires: (php-composer(sebastian/exporter) >= 4.0.5 with php-composer(sebastian/exporter) < 5)
Requires: (php-composer(sebastian/global-state) >= 5.0 with php-composer(sebastian/global-state) < 6)
Requires: (php-composer(sebastian/object-enumerator) >= 4.0.2 with php-composer(sebastian/object-enumerator) < 5)
Requires: (php-composer(sebastian/resource-operations) >= 3.0.2 with php-composer(sebastian/resource-operations) < 4)
-Requires: (php-composer(sebastian/type) >= 3.1 with php-composer(sebastian/type) < 4)
+Requires: (php-composer(sebastian/type) >= 3.2 with php-composer(sebastian/type) < 4)
Requires: (php-composer(sebastian/version) >= 3.0.1 with php-composer(sebastian/version) < 4)
# From composer.json, "suggest": {
# "ext-soap": "*",
@@ -177,14 +177,14 @@ Requires: php-phpunit-php-text-template2 >= 2.0.2
Requires: php-phpunit-php-timer5 >= 5.0.1
Requires: php-sebastian-cli-parser >= 1.0
Requires: php-sebastian-code-unit >= 1.0.5
-Requires: php-sebastian-comparator4 >= 4.0.5
+Requires: php-sebastian-comparator4 >= 4.0.8
Requires: php-sebastian-diff4 >= 4.0.2
Requires: php-sebastian-environment5 >= 5.1.2
-Requires: php-sebastian-exporter4 >= 4.0.2
+Requires: php-sebastian-exporter4 >= 4.0.5
Requires: php-sebastian-global-state5 >= 5.0
Requires: php-sebastian-object-enumerator4 >= 4.0.2
Requires: php-sebastian-resource-operations3 >= 3.0.2
-Requires: php-sebastian-type3 >= 3.1
+Requires: php-sebastian-type3 >= 3.2
Requires: php-sebastian-version3 >= 3.0.1
%endif
# Autoloader
@@ -298,6 +298,12 @@ exit $ret
%changelog
+* Sun Sep 25 2022 Remi Collet <remi@remirepo.net> - 9.5.25-1
+- update to 9.5.25
+- raise dependency on sebastian/comparator 4.0.8
+- raise dependency on sebastian/exporter 4.0.5
+- raise dependency on sebastian/type 3.2
+
* Thu Sep 1 2022 Remi Collet <remi@remirepo.net> - 9.5.24-1
- update to 9.5.24
- raise dependency on sebastian/type 3.1