summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-04 09:16:24 +0100
committerRemi Collet <remi@php.net>2023-02-04 09:16:24 +0100
commit96225efc88581c161f61c6777a15382f2cde0acb (patch)
tree3aa7d73dd02ace1f7a5cd835eafaab96c2af5452
parentdedbc3944f741f493cc4d2a748b4988951ea35c4 (diff)
update to 9.6.2
-rw-r--r--phpunit9-rpm.patch13
-rw-r--r--phpunit9.spec7
2 files changed, 14 insertions, 6 deletions
diff --git a/phpunit9-rpm.patch b/phpunit9-rpm.patch
index 0360db7..be09111 100644
--- a/phpunit9-rpm.patch
+++ b/phpunit9-rpm.patch
@@ -33,15 +33,20 @@ diff -up ./phpunit.rpm ./phpunit
}
$options = getopt('', array('prepend:'));
-@@ -95,4 +79,8 @@ unset($options);
+@@ -95,4 +79,13 @@ unset($options);
require PHPUNIT_COMPOSER_INSTALL;
-PHPUnit\TextUI\Command::main();
-+if (class_exists('PHPUnit_TextUI_Command')) {
-+ PHPUnit_TextUI_Command::main(); // PHPUnit v5 or older
++if (class_exists('PHPUnit\\TextUI\\Application')) {
++ // PHPUnit v10 or newer
++ exit((new PHPUnit\TextUI\Application)->run($_SERVER['argv']));
++} else if (class_exists('PHPUnit_TextUI_Command')) {
++ // PHPUnit v5 or older
++ PHPUnit_TextUI_Command::main();
+} else {
-+ PHPUnit\TextUI\Command::main(); // PHPUnit v6 or newer
++ // PHPUnit v6 to v9
++ PHPUnit\TextUI\Command::main();
+}
diff -up ./src/Util/Xml/SchemaFinder.php.rpm ./src/Util/Xml/SchemaFinder.php
--- ./src/Util/Xml/SchemaFinder.php.rpm 2021-12-30 09:04:15.000000000 +0100
diff --git a/phpunit9.spec b/phpunit9.spec
index 8c4e647..02509df 100644
--- a/phpunit9.spec
+++ b/phpunit9.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 70fc8be1d0b9fad56a199a4df5f9cfabfc246f84
+%global gh_commit 1a461cabfbd5b464f5d41c49a9959c63b4ecd2d1
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -25,7 +25,7 @@
%global ver_major 9
%global ver_minor 6
-%global upstream_version 9.6.0
+%global upstream_version 9.6.2
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -306,6 +306,9 @@ exit $ret
%changelog
+* Sat Feb 4 2023 Remi Collet <remi@remirepo.net> - 9.6.2-1
+- update to 9.6.2
+
* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 9.6.0-1
- update to 9.6.0