diff options
author | Remi Collet <remi@remirepo.net> | 2024-01-19 09:36:10 +0100 |
---|---|---|
committer | Remi Collet <remi@php.net> | 2024-01-19 09:36:10 +0100 |
commit | 7e49a53b53a42378eaaa2a45a5d14a8cc39e52fa (patch) | |
tree | eb36fa6d494277e1ffea1068cd6fb6f2da062f0a | |
parent | e65f2eb91fb9eabb6af05343f949347793614bc5 (diff) |
update to 9.6.16
-rwxr-xr-x | makesrc.sh | 5 | ||||
-rw-r--r-- | phpunit9.spec | 11 |
2 files changed, 10 insertions, 6 deletions
@@ -1,6 +1,7 @@ #!/bin/bash NAME=$(basename $PWD) +DATE=$(sed -n '/^%global gh_date/{s/.* //;p}' $NAME.spec) OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec) PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec) VERSION=$(sed -n '/^%global upstream_version/{s/.* //;p}' $NAME.spec) @@ -10,11 +11,11 @@ SHORT=${COMMIT:0:7} if [ -f $NAME-$VERSION-$SHORT.tgz ]; then echo "$NAME-$VERSION-$SHORT.tgz already there" else - echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n" + echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Date=$DATE\n" echo "Cloning..." rm -rf $PROJECT-$COMMIT - git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT + git clone --jobs 8 https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1 echo "Getting commit..." pushd $PROJECT-$COMMIT diff --git a/phpunit9.spec b/phpunit9.spec index dcc30ac..13a4767 100644 --- a/phpunit9.spec +++ b/phpunit9.spec @@ -12,8 +12,8 @@ # For compatibility with SCL %undefine __brp_mangle_shebangs -%global gh_commit 05017b80304e0eb3f31d90194a563fd53a6021f1 -#global gh_date 20150927 +%global gh_commit 3767b2c56ce02d01e3491046f33466a1ae60a37f +%global gh_date 2024-01-19 %global gh_short %(c=%{gh_commit}; echo ${c:0:7}) %global gh_owner sebastianbergmann %global gh_project phpunit @@ -26,12 +26,12 @@ %global ver_major 9 %global ver_minor 6 -%global upstream_version 9.6.15 +%global upstream_version 9.6.16 #global upstream_prever dev Name: %{pk_project}%{ver_major} Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}} -Release: 2%{?dist} +Release: 1%{?dist} Summary: The PHP Unit Testing framework version %{ver_major} License: BSD-3-Clause @@ -315,6 +315,9 @@ exit $ret %changelog +* Fri Jan 19 2024 Remi Collet <remi@remirepo.net> - 9.6.16-1 +- update to 9.6.16 + * Fri Dec 22 2023 Remi Collet <remi@remirepo.net> - 9.6.15-2 - fix possible autoloader issue with phpspec/prophecy |