summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-08-02 09:14:25 +0200
committerRemi Collet <remi@remirepo.net>2021-08-02 09:14:25 +0200
commit003cb4f2b006e20523be244ed4e29035d0be5a3d (patch)
tree0031daba1d290154331c6cad910ee31ae8968039
parenta39c1d7648d2c1c5ca4155dacc3fa9d0424c6a97 (diff)
update to 9.5.8
raise dependency on phar-io/manifest 2.0.3
-rw-r--r--composer.json2
-rw-r--r--phpunit9-rpm.patch55
-rw-r--r--phpunit9.spec18
3 files changed, 45 insertions, 30 deletions
diff --git a/composer.json b/composer.json
index 0db2e30..7a87432 100644
--- a/composer.json
+++ b/composer.json
@@ -30,7 +30,7 @@
"ext-xmlwriter": "*",
"doctrine/instantiator": "^1.3.1",
"myclabs/deep-copy": "^1.10.1",
- "phar-io/manifest": "^2.0.1",
+ "phar-io/manifest": "^2.0.3",
"phar-io/version": "^3.0.2",
"phpspec/prophecy": "^1.12.1",
"phpunit/php-code-coverage": "^9.2.3",
diff --git a/phpunit9-rpm.patch b/phpunit9-rpm.patch
index d3c313b..d52fde6 100644
--- a/phpunit9-rpm.patch
+++ b/phpunit9-rpm.patch
@@ -1,7 +1,7 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2021-06-07 07:17:56.000000000 +0200
-+++ ./phpunit 2021-06-07 07:18:25.769837276 +0200
-@@ -27,25 +27,12 @@ if (!ini_get('date.timezone')) {
+--- ./phpunit.rpm 2021-08-02 09:09:31.000000000 +0200
++++ ./phpunit 2021-08-02 09:09:33.927568458 +0200
+@@ -58,25 +58,12 @@ if (!ini_get('date.timezone')) {
ini_set('date.timezone', 'UTC');
}
@@ -33,7 +33,7 @@ diff -up ./phpunit.rpm ./phpunit
}
$options = getopt('', array('prepend:'));
-@@ -58,4 +45,8 @@ unset($options);
+@@ -89,4 +76,8 @@ unset($options);
require PHPUNIT_COMPOSER_INSTALL;
@@ -44,8 +44,8 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main(); // PHPUnit v6 or newer
+}
diff -up ./src/Util/Xml/SchemaFinder.php.rpm ./src/Util/Xml/SchemaFinder.php
---- ./src/Util/Xml/SchemaFinder.php.rpm 2021-06-07 07:17:56.000000000 +0200
-+++ ./src/Util/Xml/SchemaFinder.php 2021-06-07 07:18:25.769837276 +0200
+--- ./src/Util/Xml/SchemaFinder.php.rpm 2021-08-02 09:09:31.000000000 +0200
++++ ./src/Util/Xml/SchemaFinder.php 2021-08-02 09:09:33.927568458 +0200
@@ -48,6 +48,6 @@ final class SchemaFinder
return __PHPUNIT_PHAR_ROOT__ . '/';
}
@@ -55,22 +55,33 @@ diff -up ./src/Util/Xml/SchemaFinder.php.rpm ./src/Util/Xml/SchemaFinder.php
}
}
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2021-06-07 07:18:25.769837276 +0200
-+++ ./tests/bootstrap.php 2021-06-07 07:19:32.888583752 +0200
-@@ -8,7 +8,7 @@
- * file that was distributed with this source code.
+--- ./tests/bootstrap.php.rpm 2021-08-02 09:09:33.928568455 +0200
++++ ./tests/bootstrap.php 2021-08-02 09:10:37.377383177 +0200
+@@ -9,8 +9,8 @@
*/
- if (!defined('PHPUNIT_COMPOSER_INSTALL')) {
-- define('PHPUNIT_COMPOSER_INSTALL', dirname(__DIR__) . '/vendor/autoload.php');
-+ define('PHPUNIT_COMPOSER_INSTALL', '@PATH@/autoload.php');
- }
+ const TEST_FILES_PATH = __DIR__ . DIRECTORY_SEPARATOR . '_files' . DIRECTORY_SEPARATOR;
+
+-$composer = file_exists(__DIR__ . '/../vendor/autoload.php');
+-$phar = file_exists(__DIR__ . '/autoload.php');
++$composer = true;
++$phar = false;
+
+ if ($composer && $phar) {
+ print 'More than one test fixture autoloader is available, exiting.' . PHP_EOL;
+@@ -26,10 +26,14 @@ if (!$composer && !$phar) {
- if (!defined('TEST_FILES_PATH')) {
-@@ -19,3 +19,7 @@ ini_set('precision', '14');
- ini_set('serialize_precision', '14');
+ if ($composer) {
+ if (!defined('PHPUNIT_COMPOSER_INSTALL')) {
+- define('PHPUNIT_COMPOSER_INSTALL', dirname(__DIR__) . '/vendor/autoload.php');
++ define('PHPUNIT_COMPOSER_INSTALL', '@PATH@/autoload.php');
+ }
+
+- require_once __DIR__ . '/../vendor/autoload.php';
++ require_once PHPUNIT_COMPOSER_INSTALL;
++ require_once __DIR__ . '/_files/CoverageNamespacedFunctionTest.php';
++ require_once __DIR__ . '/_files/CoveredFunction.php';
++ require_once __DIR__ . '/_files/NamespaceCoveredFunction.php';
++ require_once __DIR__ . '/autoload.php';
+ }
- require_once PHPUNIT_COMPOSER_INSTALL;
-+require_once __DIR__ . '/_files/CoverageNamespacedFunctionTest.php';
-+require_once __DIR__ . '/_files/CoveredFunction.php';
-+require_once __DIR__ . '/_files/NamespaceCoveredFunction.php';
-+require_once __DIR__ . '/autoload.php';
+ if ($phar) {
diff --git a/phpunit9.spec b/phpunit9.spec
index cb86833..1b51f0d 100644
--- a/phpunit9.spec
+++ b/phpunit9.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit d0dc8b6999c937616df4fb046792004b33fd31c5
+%global gh_commit 191768ccd5c85513b4068bdbe99bb6390c7d54fb
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -25,7 +25,7 @@
%global ver_major 9
%global ver_minor 5
-%global upstream_version 9.5.7
+%global upstream_version 9.5.8
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -47,7 +47,7 @@ BuildRequires: php(language) >= 7.3
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(doctrine/instantiator) >= 1.3.1 with php-composer(doctrine/instantiator) < 2)
BuildRequires: (php-composer(myclabs/deep-copy) >= 1.10.1 with php-composer(myclabs/deep-copy) < 2)
-BuildRequires: (php-composer(phar-io/manifest) >= 2.0.1 with php-composer(phar-io/manifest) < 3)
+BuildRequires: (php-composer(phar-io/manifest) >= 2.0.3 with php-composer(phar-io/manifest) < 3)
BuildRequires: (php-composer(phar-io/version) >= 3.0.2 with php-composer(phar-io/version) < 4)
BuildRequires: (php-composer(phpspec/prophecy) >= 1.12.1 with php-composer(phpspec/prophecy) < 2)
BuildRequires: (php-composer(phpunit/php-code-coverage) >= 9.2.3 with php-composer(phpunit/php-code-coverage) < 10)
@@ -70,7 +70,7 @@ BuildRequires: (php-composer(sebastian/version) >= 3.0.1 with php-c
%else
BuildRequires: php-doctrine-instantiator >= 1.3.1
BuildRequires: php-myclabs-deep-copy >= 1.10.1
-BuildRequires: php-phar-io-manifest2 >= 2.0.1
+BuildRequires: php-phar-io-manifest2 >= 2.0.3
BuildRequires: php-phar-io-version3 >= 3.0.2
BuildRequires: php-phpspec-prophecy >= 1.12.1
BuildRequires: php-phpunit-php-code-coverage9 >= 9.2.3
@@ -109,7 +109,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "ext-xmlwriter": "*",
# "doctrine/instantiator": "^1.3.1",
# "myclabs/deep-copy": "^1.10.1",
-# "phar-io/manifest": "^2.0.1",
+# "phar-io/manifest": "^2.0.3",
# "phar-io/version": "^3.0.2",
# "phpspec/prophecy": "^1.12.1",
# "phpunit/php-code-coverage": "^9.2.3",
@@ -140,7 +140,7 @@ Requires: php-xmlwriter
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(doctrine/instantiator) >= 1.3.1 with php-composer(doctrine/instantiator) < 2)
Requires: (php-composer(myclabs/deep-copy) >= 1.10.1 with php-composer(myclabs/deep-copy) < 2)
-Requires: (php-composer(phar-io/manifest) >= 2.0.1 with php-composer(phar-io/manifest) < 3)
+Requires: (php-composer(phar-io/manifest) >= 2.0.3 with php-composer(phar-io/manifest) < 3)
Requires: (php-composer(phar-io/version) >= 3.0.2 with php-composer(phar-io/version) < 4)
Requires: (php-composer(phpspec/prophecy) >= 1.12.1 with php-composer(phpspec/prophecy) < 2)
Requires: (php-composer(phpunit/php-code-coverage) >= 9.2.3 with php-composer(phpunit/php-code-coverage) < 10)
@@ -168,7 +168,7 @@ Suggests: php-xdebug
%else
Requires: php-doctrine-instantiator >= 1.3.1
Requires: php-myclabs-deep-copy >= 1.10.1
-Requires: php-phar-io-manifest2 >= 2.0.1
+Requires: php-phar-io-manifest2 >= 2.0.3
Requires: php-phar-io-version3 >= 3.0.2
Requires: php-phpspec-prophecy >= 1.12.1
Requires: php-phpunit-php-code-coverage9 >= 9.2.3
@@ -303,6 +303,10 @@ exit $ret
%changelog
+* Mon Aug 2 2021 Remi Collet <remi@remirepo.net> - 9.5.8-1
+- update to 9.5.8
+- raise dependency on phar-io/manifest 2.0.3
+
* Mon Jul 19 2021 Remi Collet <remi@remirepo.net> - 9.5.7-1
- update to 9.5.7