summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--phpunit8.spec18
2 files changed, 12 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index e7f0424..4b68259 100644
--- a/composer.json
+++ b/composer.json
@@ -40,7 +40,7 @@
"sebastian/comparator": "^3.0.2",
"sebastian/diff": "^3.0.2",
"sebastian/environment": "^4.2.2",
- "sebastian/exporter": "^3.1.0",
+ "sebastian/exporter": "^3.1.1",
"sebastian/global-state": "^3.0.0",
"sebastian/object-enumerator": "^3.0.3",
"sebastian/resource-operations": "^2.0.1",
diff --git a/phpunit8.spec b/phpunit8.spec
index bf79b21..d295231 100644
--- a/phpunit8.spec
+++ b/phpunit8.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit e31cce0cf4499c0ccdbbb211a3280d36ab341e36
+%global gh_commit 302faed7059fde575cf3403a78c730c5e3a62750
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -24,7 +24,7 @@
%global php_home %{_datadir}/php
%global ver_major 8
%global ver_minor 3
-%global ver_patch 4
+%global ver_patch 5
%global specrel 1
Name: %{pk_project}%{ver_major}
@@ -55,7 +55,7 @@ BuildRequires: (php-composer(phpunit/php-timer) >= 2.1.2 with php-c
BuildRequires: (php-composer(sebastian/comparator) >= 3.0.2 with php-composer(sebastian/comparator) < 4)
BuildRequires: (php-composer(sebastian/diff) >= 3.0.2 with php-composer(sebastian/diff) < 4)
BuildRequires: (php-composer(sebastian/environment) >= 4.2.2 with php-composer(sebastian/environment) < 5)
-BuildRequires: (php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4)
+BuildRequires: (php-composer(sebastian/exporter) >= 3.1.1 with php-composer(sebastian/exporter) < 4)
BuildRequires: (php-composer(sebastian/global-state) >= 3.0.0 with php-composer(sebastian/global-state) < 4)
BuildRequires: (php-composer(sebastian/object-enumerator) >= 3.0.3 with php-composer(sebastian/object-enumerator) < 4)
BuildRequires: (php-composer(sebastian/resource-operations) >= 2.0.1 with php-composer(sebastian/resource-operations) < 3)
@@ -76,7 +76,7 @@ BuildRequires: php-phpunit-php-timer2 >= 2.1.2
BuildRequires: php-sebastian-comparator3 >= 3.0.2
BuildRequires: php-sebastian-diff3 >= 3.0.2
BuildRequires: php-sebastian-environment4 >= 4.2.2
-BuildRequires: php-sebastian-exporter3 >= 3.1
+BuildRequires: php-sebastian-exporter3 >= 3.1.1
BuildRequires: php-sebastian-global-state3
BuildRequires: php-sebastian-object-enumerator3 >= 3.0.3
BuildRequires: php-sebastian-resource-operations2 >= 2.0.1
@@ -113,7 +113,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "sebastian/comparator": "^3.0.2",
# "sebastian/diff": "^3.0.2",
# "sebastian/environment": "^4.2.2",
-# "sebastian/exporter": "^3.1",
+# "sebastian/exporter": "^3.1.1",
# "sebastian/global-state": "^3.0.0",
# "sebastian/object-enumerator": "^3.0.3",
# "sebastian/resource-operations": "^2.0.1",
@@ -141,7 +141,7 @@ Requires: (php-composer(phpunit/php-timer) >= 2.1.2 with php-c
Requires: (php-composer(sebastian/comparator) >= 3.0.2 with php-composer(sebastian/comparator) < 4)
Requires: (php-composer(sebastian/diff) >= 3.0.2 with php-composer(sebastian/diff) < 4)
Requires: (php-composer(sebastian/environment) >= 4.2.2 with php-composer(sebastian/environment) < 5)
-Requires: (php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4)
+Requires: (php-composer(sebastian/exporter) >= 3.1.1 with php-composer(sebastian/exporter) < 4)
Requires: (php-composer(sebastian/global-state) >= 3.0.0 with php-composer(sebastian/global-state) < 4)
Requires: (php-composer(sebastian/object-enumerator) >= 3.0.3 with php-composer(sebastian/object-enumerator) < 4)
Requires: (php-composer(sebastian/resource-operations) >= 2.0.1 with php-composer(sebastian/resource-operations) < 3)
@@ -168,7 +168,7 @@ Requires: php-phpunit-php-timer2 >= 2.1.2
Requires: php-sebastian-comparator3 >= 3.0.2
Requires: php-sebastian-diff3 >= 3.0.2
Requires: php-sebastian-environment4 >= 4.2.2
-Requires: php-sebastian-exporter3 >= 3.1
+Requires: php-sebastian-exporter3 >= 3.1.1
Requires: php-sebastian-global-state3
Requires: php-sebastian-object-enumerator3 >= 3.0.3
Requires: php-sebastian-resource-operations2 >= 2.0.1
@@ -280,6 +280,10 @@ exit $ret
%changelog
+* Sun Sep 15 2019 Remi Collet <remi@remirepo.net> - 8.3.5-1
+- update to 8.3.5
+- raise dependency on sebastian/exporter 3.1.1
+
* Mon Aug 12 2019 Remi Collet <remi@remirepo.net> - 8.3.4-1
- update to 8.3.4