diff options
author | Remi Collet <remi@remirepo.net> | 2024-07-11 07:08:13 +0200 |
---|---|---|
committer | Remi Collet <remi@php.net> | 2024-07-11 07:08:13 +0200 |
commit | fb3490a5fc9336baaddc2554fa5d13f3002dd03a (patch) | |
tree | 76a39846b8f5a842ab927294cbc2c34616ab176c /makesrc.sh | |
parent | f59489d140651770f58a14b19243fdabf97a0236 (diff) |
update to 8.5.39
raise dependencies
Diffstat (limited to 'makesrc.sh')
-rwxr-xr-x | makesrc.sh | 11 |
1 files changed, 8 insertions, 3 deletions
@@ -1,24 +1,29 @@ #!/bin/bash NAME=$(basename $PWD) +DATE=$(sed -n '/^%global gh_date/{s/.* //;p}' $NAME.spec) OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec) PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec) VERSION=$(sed -n '/^%global upstream_version/{s/.* //;p}' $NAME.spec) +MAJOR=$(sed -n '/^%global ver_major/{s/.* //;p}' $NAME.spec) +MINOR=$(sed -n '/^%global ver_minor/{s/.* //;p}' $NAME.spec) COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec) SHORT=${COMMIT:0:7} +DATE=$(date -d "$DATE -1 week" +%Y-%m-%d) + if [ -f $NAME-$VERSION-$SHORT.tgz ]; then echo "$NAME-$VERSION-$SHORT.tgz already there" else - echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n" + echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Date=$DATE\n" echo "Cloning..." rm -rf $PROJECT-$COMMIT - git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT + git clone --branch $MAJOR.$MINOR --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1 echo "Getting commit..." pushd $PROJECT-$COMMIT - git checkout $COMMIT || exit1 + git checkout $COMMIT || exit 1 cp composer.json ../composer.json popd |