summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-08-02 09:08:53 +0200
committerRemi Collet <remi@remirepo.net>2021-08-02 09:08:53 +0200
commite870f2f9110f88ebe838c279adb16202f18855ae (patch)
tree230eb37ccb002ce268e5b3e66451b10817807f54
parent9816d8ac7f7fb031ecd3550f97e66066b4f88c03 (diff)
update to 8.5.19
raise dependency on phar-io/manifest 2.0.3 raise dependency on phpunit/php-file-iterator 2.0.4
-rw-r--r--composer.json4
-rw-r--r--phpunit8-rpm.patch57
-rw-r--r--phpunit8.spec29
3 files changed, 53 insertions, 37 deletions
diff --git a/composer.json b/composer.json
index 86f7b21..7ca2f67 100644
--- a/composer.json
+++ b/composer.json
@@ -30,11 +30,11 @@
"ext-xmlwriter": "*",
"doctrine/instantiator": "^1.3.1",
"myclabs/deep-copy": "^1.10.0",
- "phar-io/manifest": "^2.0.1",
+ "phar-io/manifest": "^2.0.3",
"phar-io/version": "^3.0.2",
"phpspec/prophecy": "^1.10.3",
"phpunit/php-code-coverage": "^7.0.12",
- "phpunit/php-file-iterator": "^2.0.2",
+ "phpunit/php-file-iterator": "^2.0.4",
"phpunit/php-text-template": "^1.2.1",
"phpunit/php-timer": "^2.1.2",
"sebastian/comparator": "^3.0.2",
diff --git a/phpunit8-rpm.patch b/phpunit8-rpm.patch
index 530819f..12bef82 100644
--- a/phpunit8-rpm.patch
+++ b/phpunit8-rpm.patch
@@ -1,7 +1,7 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2021-06-07 07:13:03.000000000 +0200
-+++ ./phpunit 2021-06-07 07:13:10.372992677 +0200
-@@ -27,25 +27,12 @@ if (!ini_get('date.timezone')) {
+--- ./phpunit.rpm 2021-08-02 08:27:58.000000000 +0200
++++ ./phpunit 2021-08-02 08:34:41.313976887 +0200
+@@ -58,25 +58,12 @@ if (!ini_get('date.timezone')) {
ini_set('date.timezone', 'UTC');
}
@@ -33,7 +33,7 @@ diff -up ./phpunit.rpm ./phpunit
}
$options = getopt('', array('prepend:'));
-@@ -58,4 +45,8 @@ unset($options);
+@@ -89,4 +76,8 @@ unset($options);
require PHPUNIT_COMPOSER_INSTALL;
@@ -44,8 +44,8 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main(); // PHPUnit v6 or newer
+}
diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
---- ./src/Util/Configuration.php.rpm 2021-06-07 07:13:03.000000000 +0200
-+++ ./src/Util/Configuration.php 2021-06-07 07:13:10.372992677 +0200
+--- ./src/Util/Configuration.php.rpm 2021-08-02 08:27:58.000000000 +0200
++++ ./src/Util/Configuration.php 2021-08-02 08:34:40.070979790 +0200
@@ -929,7 +929,7 @@ final class Configuration
private function validateConfigurationAgainstSchema(): void
{
@@ -56,23 +56,34 @@ diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
if (defined('__PHPUNIT_PHAR_ROOT__')) {
$xsdFilename = __PHPUNIT_PHAR_ROOT__ . '/phpunit.xsd';
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2021-06-07 07:13:10.372992677 +0200
-+++ ./tests/bootstrap.php 2021-06-07 07:15:29.571502817 +0200
-@@ -8,7 +8,7 @@
- * file that was distributed with this source code.
+--- ./tests/bootstrap.php.rpm 2021-08-02 08:27:58.000000000 +0200
++++ ./tests/bootstrap.php 2021-08-02 08:44:30.257601265 +0200
+@@ -9,8 +9,8 @@
*/
- if (!defined('PHPUNIT_COMPOSER_INSTALL')) {
-- define('PHPUNIT_COMPOSER_INSTALL', dirname(__DIR__) . '/vendor/autoload.php');
-+ define('PHPUNIT_COMPOSER_INSTALL', '@PATH@/autoload.php');
- }
+ const TEST_FILES_PATH = __DIR__ . DIRECTORY_SEPARATOR . '_files' . DIRECTORY_SEPARATOR;
+
+-$composer = file_exists(__DIR__ . '/../vendor/autoload.php');
+-$phar = file_exists(__DIR__ . '/autoload.php');
++$composer = true;
++$phar = false;
+
+ if ($composer && $phar) {
+ print 'More than one test fixture autoloader is available, exiting.' . PHP_EOL;
+@@ -26,10 +26,15 @@ if (!$composer && !$phar) {
- if (!defined('TEST_FILES_PATH')) {
-@@ -19,3 +19,8 @@ ini_set('precision', '14');
- ini_set('serialize_precision', '14');
+ if ($composer) {
+ if (!defined('PHPUNIT_COMPOSER_INSTALL')) {
+- define('PHPUNIT_COMPOSER_INSTALL', dirname(__DIR__) . '/vendor/autoload.php');
++ define('PHPUNIT_COMPOSER_INSTALL', '@PATH@/autoload.php');
+ }
+
+- require_once __DIR__ . '/../vendor/autoload.php';
++ require_once PHPUNIT_COMPOSER_INSTALL;
++ require_once __DIR__ . '/_files/CoverageNamespacedFunctionTest.php';
++ require_once __DIR__ . '/_files/CoveredFunction.php';
++ require_once __DIR__ . '/_files/NamespaceCoveredFunction.php';
++ require_once '@PATH@//Framework/Assert/Functions.php';
++ require_once __DIR__ . '/autoload.php';
+ }
- require_once PHPUNIT_COMPOSER_INSTALL;
-+require_once __DIR__ . '/_files/CoverageNamespacedFunctionTest.php';
-+require_once __DIR__ . '/_files/CoveredFunction.php';
-+require_once __DIR__ . '/_files/NamespaceCoveredFunction.php';
-+require_once '@PATH@/Framework/Assert/Functions.php';
-+require_once __DIR__ . '/autoload.php';
+ if ($phar) {
diff --git a/phpunit8.spec b/phpunit8.spec
index a567e94..0905afe 100644
--- a/phpunit8.spec
+++ b/phpunit8.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit bd5fc77c869e8dd65040dacbad170f074c13796c
+%global gh_commit 496281b64ec781856ed0a583483b5923b4033722
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -25,7 +25,7 @@
%global ver_major 8
%global ver_minor 5
-%global upstream_version 8.5.18
+%global upstream_version 8.5.19
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -47,11 +47,11 @@ BuildRequires: php(language) >= 7.2
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(doctrine/instantiator) >= 1.3.1 with php-composer(doctrine/instantiator) < 2)
BuildRequires: (php-composer(myclabs/deep-copy) >= 1.10.0 with php-composer(myclabs/deep-copy) < 2)
-BuildRequires: (php-composer(phar-io/manifest) >= 2.0.1 with php-composer(phar-io/manifest) < 3)
+BuildRequires: (php-composer(phar-io/manifest) >= 2.0.3 with php-composer(phar-io/manifest) < 3)
BuildRequires: (php-composer(phar-io/version) >= 3.0.2 with php-composer(phar-io/version) < 4)
BuildRequires: (php-composer(phpspec/prophecy) >= 1.10.3 with php-composer(phpspec/prophecy) < 2)
BuildRequires: (php-composer(phpunit/php-code-coverage) >= 7.0.12 with php-composer(phpunit/php-code-coverage) < 8)
-BuildRequires: (php-composer(phpunit/php-file-iterator) >= 2.0.2 with php-composer(phpunit/php-file-iterator) < 3)
+BuildRequires: (php-composer(phpunit/php-file-iterator) >= 2.0.4 with php-composer(phpunit/php-file-iterator) < 3)
BuildRequires: (php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2)
BuildRequires: (php-composer(phpunit/php-timer) >= 2.1.2 with php-composer(phpunit/php-timer) < 3)
BuildRequires: (php-composer(sebastian/comparator) >= 3.0.2 with php-composer(sebastian/comparator) < 4)
@@ -68,11 +68,11 @@ BuildRequires: (php-composer(phpunit/php-invoker) >= 2.0.0 with php-c
%else
BuildRequires: php-doctrine-instantiator >= 1.3.1
BuildRequires: php-myclabs-deep-copy >= 1.10.0
-BuildRequires: php-phar-io-manifest2 >= 2.0.1
+BuildRequires: php-phar-io-manifest2 >= 2.0.3
BuildRequires: php-phar-io-version3 >= 3.0.2
BuildRequires: php-phpspec-prophecy >= 1.10.3
BuildRequires: php-phpunit-php-code-coverage7 >= 7.0.12
-BuildRequires: php-phpunit-php-file-iterator2 >= 2.0.2
+BuildRequires: php-phpunit-php-file-iterator2 >= 2.0.4
BuildRequires: php-phpunit-Text-Template >= 1.2.1
BuildRequires: php-phpunit-php-timer2 >= 2.1.2
BuildRequires: php-sebastian-comparator3 >= 3.0.2
@@ -105,11 +105,11 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "ext-xmlwriter": "*",
# "doctrine/instantiator": "^1.3.1",
# "myclabs/deep-copy": "^1.10.0",
-# "phar-io/manifest": "^2.0.1",
+# "phar-io/manifest": "^2.0.3",
# "phar-io/version": "^3.0.2",
# "phpspec/prophecy": "^1.10.3",
# "phpunit/php-code-coverage": "^7.0.10",
-# "phpunit/php-file-iterator": "^2.0.2",
+# "phpunit/php-file-iterator": "^2.0.4",
# "phpunit/php-text-template": "^1.2.1",
# "phpunit/php-timer": "^2.1.2",
# "sebastian/comparator": "^3.0.2",
@@ -133,11 +133,11 @@ Requires: php-xmlwriter
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(doctrine/instantiator) >= 1.3.1 with php-composer(doctrine/instantiator) < 2)
Requires: (php-composer(myclabs/deep-copy) >= 1.10.0 with php-composer(myclabs/deep-copy) < 2)
-Requires: (php-composer(phar-io/manifest) >= 2.0.1 with php-composer(phar-io/manifest) < 3)
+Requires: (php-composer(phar-io/manifest) >= 2.0.3 with php-composer(phar-io/manifest) < 3)
Requires: (php-composer(phar-io/version) >= 3.0.2 with php-composer(phar-io/version) < 4)
Requires: (php-composer(phpspec/prophecy) >= 1.10.3 with php-composer(phpspec/prophecy) < 2)
Requires: (php-composer(phpunit/php-code-coverage) >= 7.0.12 with php-composer(phpunit/php-code-coverage) < 8)
-Requires: (php-composer(phpunit/php-file-iterator) >= 2.0.2 with php-composer(phpunit/php-file-iterator) < 3)
+Requires: (php-composer(phpunit/php-file-iterator) >= 2.0.4 with php-composer(phpunit/php-file-iterator) < 3)
Requires: (php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2)
Requires: (php-composer(phpunit/php-timer) >= 2.1.2 with php-composer(phpunit/php-timer) < 3)
Requires: (php-composer(sebastian/comparator) >= 3.0.2 with php-composer(sebastian/comparator) < 4)
@@ -160,11 +160,11 @@ Suggests: php-xdebug
%else
Requires: php-doctrine-instantiator >= 1.3.1
Requires: php-myclabs-deep-copy >= 1.10.0
-Requires: php-phar-io-manifest2 >= 2.0.1
+Requires: php-phar-io-manifest2 >= 2.0.3
Requires: php-phar-io-version3 >= 3.0.2
Requires: php-phpspec-prophecy >= 1.10.3
Requires: php-phpunit-php-code-coverage7 >= 7.0.12
-Requires: php-phpunit-php-file-iterator2 >= 2.0.2
+Requires: php-phpunit-php-file-iterator2 >= 2.0.4
Requires: php-phpunit-Text-Template >= 1.2.1
Requires: php-phpunit-php-timer2 >= 2.1.2
Requires: php-sebastian-comparator3 >= 3.0.2
@@ -283,6 +283,11 @@ exit $ret
%changelog
+* Mon Aug 2 2021 Remi Collet <remi@remirepo.net> - 8.5.19-1
+- update to 8.5.19
+- raise dependency on phar-io/manifest 2.0.3
+- raise dependency on phpunit/php-file-iterator 2.0.4
+
* Mon Jul 19 2021 Remi Collet <remi@remirepo.net> - 8.5.18-1
- update to 8.5.18