summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-02-03 14:07:27 +0100
committerRemi Collet <remi@remirepo.net>2021-02-03 14:07:27 +0100
commite544beb8197b5337dc0aecb3c921d23ccccfcf16 (patch)
treef95008309dfa61608dfb750c02f76a94746e690d
parentca0633661107992244149cb185c1885f753a2bd2 (diff)
update to 8.5.14
-rw-r--r--phpunit8-rpm.patch18
-rw-r--r--phpunit8.spec9
2 files changed, 15 insertions, 12 deletions
diff --git a/phpunit8-rpm.patch b/phpunit8-rpm.patch
index b66a4d2..f4e4c9f 100644
--- a/phpunit8-rpm.patch
+++ b/phpunit8-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2020-11-10 16:52:55.000000000 +0100
-+++ ./phpunit 2020-11-10 16:58:06.470107562 +0100
+--- ./phpunit.rpm 2021-02-03 14:04:11.000000000 +0100
++++ ./phpunit 2021-02-03 14:04:57.662439204 +0100
@@ -27,25 +27,12 @@ if (!ini_get('date.timezone')) {
ini_set('date.timezone', 'UTC');
}
@@ -44,20 +44,20 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main(); // PHPUnit v6 or newer
+}
diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
---- ./src/Util/Configuration.php.rpm 2020-11-10 16:58:06.470107562 +0100
-+++ ./src/Util/Configuration.php 2020-11-10 16:59:17.462913118 +0100
-@@ -903,7 +903,7 @@ final class Configuration
+--- ./src/Util/Configuration.php.rpm 2021-02-03 14:04:57.662439204 +0100
++++ ./src/Util/Configuration.php 2021-02-03 14:06:08.876097281 +0100
+@@ -929,7 +929,7 @@ final class Configuration
private function validateConfigurationAgainstSchema(): void
{
- $original = \libxml_use_internal_errors(true);
+ $original = libxml_use_internal_errors(true);
- $xsdFilename = __DIR__ . '/../../phpunit.xsd';
+ $xsdFilename = __DIR__ . '/../phpunit.xsd';
- if (\defined('__PHPUNIT_PHAR_ROOT__')) {
+ if (defined('__PHPUNIT_PHAR_ROOT__')) {
$xsdFilename = __PHPUNIT_PHAR_ROOT__ . '/phpunit.xsd';
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2020-11-10 16:52:55.000000000 +0100
-+++ ./tests/bootstrap.php 2020-11-10 16:58:06.470107562 +0100
+--- ./tests/bootstrap.php.rpm 2021-02-03 14:04:11.000000000 +0100
++++ ./tests/bootstrap.php 2021-02-03 14:04:57.662439204 +0100
@@ -14,4 +14,9 @@ if (!\defined('TEST_FILES_PATH')) {
\ini_set('precision', '14');
\ini_set('serialize_precision', '14');
diff --git a/phpunit8.spec b/phpunit8.spec
index 7e4d124..f747ccb 100644
--- a/phpunit8.spec
+++ b/phpunit8.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for phpunit8
#
-# Copyright (c) 2010-2020 Remi Collet
+# Copyright (c) 2010-2021 Remi Collet
#
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 8e86be391a58104ef86037ba8a846524528d784e
+%global gh_commit c25f79895d27b6ecd5abfa63de1606b786a461a3
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -27,7 +27,7 @@
%global specrel 1
Name: %{pk_project}%{ver_major}
-Version: 8.5.13
+Version: 8.5.14
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: The PHP Unit Testing framework version %{ver_major}
@@ -281,6 +281,9 @@ exit $ret
%changelog
+* Wed Feb 3 2021 Remi Collet <remi@remirepo.net> - 8.5.14-1
+- update to 8.5.14
+
* Tue Dec 1 2020 Remi Collet <remi@remirepo.net> - 8.5.13-1
- update to 8.5.13