summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-04 09:23:10 +0100
committerRemi Collet <remi@php.net>2023-02-04 09:23:10 +0100
commitbfde5364869c4aad6331272c6a3502b30264c49d (patch)
treed8cd7f16ec63a769e2e25b74766df6a8b60b9840
parentc9823307ae90c918cfa96d2266bd862f76a5e92f (diff)
adapt launcher for phpunit10
-rw-r--r--phpunit8-rpm.patch13
-rw-r--r--phpunit8.spec5
2 files changed, 13 insertions, 5 deletions
diff --git a/phpunit8-rpm.patch b/phpunit8-rpm.patch
index 2fe8780..25cd8f0 100644
--- a/phpunit8-rpm.patch
+++ b/phpunit8-rpm.patch
@@ -33,15 +33,20 @@ diff -up ./phpunit.rpm ./phpunit
}
$options = getopt('', array('prepend:'));
-@@ -95,4 +79,8 @@ unset($options);
+@@ -95,4 +79,13 @@ unset($options);
require PHPUNIT_COMPOSER_INSTALL;
-PHPUnit\TextUI\Command::main();
-+if (class_exists('PHPUnit_TextUI_Command')) {
-+ PHPUnit_TextUI_Command::main(); // PHPUnit v5 or older
++if (class_exists('PHPUnit\\TextUI\\Application')) {
++ // PHPUnit v10 or newer
++ exit((new PHPUnit\TextUI\Application)->run($_SERVER['argv']));
++} else if (class_exists('PHPUnit_TextUI_Command')) {
++ // PHPUnit v5 or older
++ PHPUnit_TextUI_Command::main();
+} else {
-+ PHPUnit\TextUI\Command::main(); // PHPUnit v6 or newer
++ // PHPUnit v6 to v9
++ PHPUnit\TextUI\Command::main();
+}
diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
--- ./src/Util/Configuration.php.rpm 2021-12-30 08:58:05.000000000 +0100
diff --git a/phpunit8.spec b/phpunit8.spec
index 8ff58ea..61db3f7 100644
--- a/phpunit8.spec
+++ b/phpunit8.spec
@@ -30,7 +30,7 @@
Name: %{pk_project}%{ver_major}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: The PHP Unit Testing framework version %{ver_major}
License: BSD-3-Clause
@@ -282,6 +282,9 @@ exit $ret
%changelog
+* Sat Feb 4 2023 Remi Collet <remi@remirepo.net> - 8.5.32-2
+- adapt launcher for phpunit10
+
* Thu Jan 26 2023 Remi Collet <remi@remirepo.net> - 8.5.32-1
- update to 8.5.32