summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-07 07:17:27 +0200
committerRemi Collet <remi@remirepo.net>2021-06-07 07:17:27 +0200
commita9571b3112146d127d0c01bd8e15c705223bf68b (patch)
treeddccdf58334e6df45fccaebf8a97ea3ee6bf937d
parent93dedc42f12f3f8e71d55ad3b6c886ac14408ad8 (diff)
update to 8.5.16
-rw-r--r--phpunit8-rpm.patch29
-rw-r--r--phpunit8.spec7
2 files changed, 23 insertions, 13 deletions
diff --git a/phpunit8-rpm.patch b/phpunit8-rpm.patch
index f4e4c9f..530819f 100644
--- a/phpunit8-rpm.patch
+++ b/phpunit8-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2021-02-03 14:04:11.000000000 +0100
-+++ ./phpunit 2021-02-03 14:04:57.662439204 +0100
+--- ./phpunit.rpm 2021-06-07 07:13:03.000000000 +0200
++++ ./phpunit 2021-06-07 07:13:10.372992677 +0200
@@ -27,25 +27,12 @@ if (!ini_get('date.timezone')) {
ini_set('date.timezone', 'UTC');
}
@@ -44,8 +44,8 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main(); // PHPUnit v6 or newer
+}
diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
---- ./src/Util/Configuration.php.rpm 2021-02-03 14:04:57.662439204 +0100
-+++ ./src/Util/Configuration.php 2021-02-03 14:06:08.876097281 +0100
+--- ./src/Util/Configuration.php.rpm 2021-06-07 07:13:03.000000000 +0200
++++ ./src/Util/Configuration.php 2021-06-07 07:13:10.372992677 +0200
@@ -929,7 +929,7 @@ final class Configuration
private function validateConfigurationAgainstSchema(): void
{
@@ -56,14 +56,21 @@ diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
if (defined('__PHPUNIT_PHAR_ROOT__')) {
$xsdFilename = __PHPUNIT_PHAR_ROOT__ . '/phpunit.xsd';
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2021-02-03 14:04:11.000000000 +0100
-+++ ./tests/bootstrap.php 2021-02-03 14:04:57.662439204 +0100
-@@ -14,4 +14,9 @@ if (!\defined('TEST_FILES_PATH')) {
- \ini_set('precision', '14');
- \ini_set('serialize_precision', '14');
+--- ./tests/bootstrap.php.rpm 2021-06-07 07:13:10.372992677 +0200
++++ ./tests/bootstrap.php 2021-06-07 07:15:29.571502817 +0200
+@@ -8,7 +8,7 @@
+ * file that was distributed with this source code.
+ */
+ if (!defined('PHPUNIT_COMPOSER_INSTALL')) {
+- define('PHPUNIT_COMPOSER_INSTALL', dirname(__DIR__) . '/vendor/autoload.php');
++ define('PHPUNIT_COMPOSER_INSTALL', '@PATH@/autoload.php');
+ }
+
+ if (!defined('TEST_FILES_PATH')) {
+@@ -19,3 +19,8 @@ ini_set('precision', '14');
+ ini_set('serialize_precision', '14');
--require_once __DIR__ . '/../vendor/autoload.php';
-+require_once '@PATH@/autoload.php';
+ require_once PHPUNIT_COMPOSER_INSTALL;
+require_once __DIR__ . '/_files/CoverageNamespacedFunctionTest.php';
+require_once __DIR__ . '/_files/CoveredFunction.php';
+require_once __DIR__ . '/_files/NamespaceCoveredFunction.php';
diff --git a/phpunit8.spec b/phpunit8.spec
index 8b0efee..e7eff64 100644
--- a/phpunit8.spec
+++ b/phpunit8.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 038d4196d8e8cb405cd5e82cedfe413ad6eef9ef
+%global gh_commit cc66f2fc61296be66c99931a862200e7456b9a01
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -25,7 +25,7 @@
%global ver_major 8
%global ver_minor 5
-%global upstream_version 8.5.15
+%global upstream_version 8.5.16
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -283,6 +283,9 @@ exit $ret
%changelog
+* Mon Jun 7 2021 Remi Collet <remi@remirepo.net> - 8.5.16-1
+- update to 8.5.16
+
* Wed Mar 17 2021 Remi Collet <remi@remirepo.net> - 8.5.15-1
- update to 8.5.15