summaryrefslogtreecommitdiffstats
path: root/phpunit6.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-03 09:06:19 +0200
committerRemi Collet <remi@remirepo.net>2018-07-03 09:06:19 +0200
commita9c8a79c4e4f0619084bcc17cb413b8a85a4eea0 (patch)
treef75da7d4ddaecd75da5460ed7d615efc3d2c3a82 /phpunit6.spec
parent041348244b6062f6a59a1748007cb93d9b08ffee (diff)
v6.5.9
Diffstat (limited to 'phpunit6.spec')
-rw-r--r--phpunit6.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/phpunit6.spec b/phpunit6.spec
index 6e5319e..3839d34 100644
--- a/phpunit6.spec
+++ b/phpunit6.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 4f21a3c6b97c42952fd5c2837bb354ec0199b97b
+%global gh_commit 093ca5508174cd8ab8efe44fd1dde447adfdec8f
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -24,7 +24,7 @@
%global php_home %{_datadir}/php
%global ver_major 6
%global ver_minor 5
-%global ver_patch 8
+%global ver_patch 9
%global specrel 1
Name: %{pk_project}%{ver_major}
@@ -42,7 +42,7 @@ Patch0: %{name}-rpm.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.0
# remirepo:1
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(myclabs/deep-copy) >= 1.6.1 with php-composer(myclabs/deep-copy) < 2)
BuildRequires: (php-composer(phar-io/manifest) >= 1.0.1 with php-composer(phar-io/manifest) < 2)
BuildRequires: (php-composer(phar-io/version) >= 1.0 with php-composer(phar-io/version) < 2)
@@ -122,7 +122,7 @@ Requires: php-libxml
Requires: php-mbstring
Requires: php-xml
# remirepo:1
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(myclabs/deep-copy) >= 1.6.1 with php-composer(myclabs/deep-copy) < 2)
Requires: (php-composer(phar-io/manifest) >= 1.0.1 with php-composer(phar-io/manifest) < 2)
Requires: (php-composer(phar-io/version) >= 1.0 with php-composer(phar-io/version) < 2)
@@ -175,7 +175,7 @@ Requires: php-pcre
Requires: php-phar
Requires: php-spl
# remirepo:1
-%if 0%{?fedora} > 21
+%if 0%{?fedora} > 21 || 0%{?rhel} >= 8
Recommends: php-phpunit-dbunit3
Suggests: php-phpunit-selenium
# remirepo:1
@@ -201,13 +201,13 @@ It is an instance of the xUnit architecture for unit testing frameworks.
cat << 'EOF' | tee -a src/autoload.php
// Dependencies
\Fedora\Autoloader\Dependencies::required([
+ 'SebastianBergmann/Diff2/autoload.php', // Before comparator which may load v3
'File/Iterator/Autoload.php',
'Text/Template/Autoload.php',
'SebastianBergmann/CodeCoverage5/autoload.php',
'PHP/Timer/Autoload.php',
'%{ns_vendor}/Framework/MockObject5/autoload.php',
'Prophecy/autoload.php',
- 'SebastianBergmann/Diff2/autoload.php', // Before comparator which may load v3
'SebastianBergmann/Comparator2/autoload.php',
'SebastianBergmann/Environment3/autoload.php',
'SebastianBergmann/Exporter3/autoload.php',
@@ -247,7 +247,7 @@ OPT="--testsuite=small --no-coverage"
sed -e 's:@PATH@:%{buildroot}%{php_home}/%{ns_vendor}:' -i tests/bootstrap.php
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
$cmd -d include_path=.:%{buildroot}%{php_home}:%{php_home} ./phpunit $OPT --verbose || ret=1
fi
@@ -265,6 +265,9 @@ exit $ret
%changelog
+* Tue Jul 3 2018 Remi Collet <remi@remirepo.net> - 6.5.9-1
+- update to 6.5.9
+
* Tue Apr 10 2018 Remi Collet <remi@remirepo.net> - 6.5.8-1
- update to 6.5.8