summaryrefslogtreecommitdiffstats
path: root/phpunit12.spec
diff options
context:
space:
mode:
Diffstat (limited to 'phpunit12.spec')
-rw-r--r--phpunit12.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/phpunit12.spec b/phpunit12.spec
index bf3454f..8477f7d 100644
--- a/phpunit12.spec
+++ b/phpunit12.spec
@@ -19,8 +19,8 @@
%bcond_with defcmd
%endif
-%global gh_commit 24b58d4900e2a45dd2172e865b9c15ccee66c3e1
-%global gh_date 2025-02-07
+%global gh_commit 6301fe5c1f5f34192ffd650a87fe055677a32212
+%global gh_date 2025-02-08
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -33,7 +33,7 @@
%global ver_major 12
%global ver_minor 0
-%global upstream_version 12.0.1
+%global upstream_version 12.0.2
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -55,7 +55,7 @@ BuildRequires: php(language) >= 8.3
BuildRequires: (php-composer(myclabs/deep-copy) >= 1.12.1 with php-composer(myclabs/deep-copy) < 2)
BuildRequires: (php-composer(phar-io/manifest) >= 2.0.4 with php-composer(phar-io/manifest) < 3)
BuildRequires: (php-composer(phar-io/version) >= 3.2.1 with php-composer(phar-io/version) < 4)
-BuildRequires: (php-composer(phpunit/php-code-coverage) >= 12.0.0 with php-composer(phpunit/php-code-coverage) < 13)
+BuildRequires: (php-composer(phpunit/php-code-coverage) >= 12.0.2 with php-composer(phpunit/php-code-coverage) < 13)
BuildRequires: (php-composer(phpunit/php-file-iterator) >= 6.0.0 with php-composer(phpunit/php-file-iterator) < 7)
BuildRequires: (php-composer(phpunit/php-invoker) >= 6.0.0 with php-composer(phpunit/php-invoker) < 7)
BuildRequires: (php-composer(phpunit/php-text-template) >= 5.0.0 with php-composer(phpunit/php-text-template) < 6)
@@ -90,7 +90,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "myclabs/deep-copy": "^1.12.1",
# "phar-io/manifest": "^2.0.4",
# "phar-io/version": "^3.2.1",
-# "phpunit/php-code-coverage": "^12.0.0",
+# "phpunit/php-code-coverage": "^12.0.2",
# "phpunit/php-file-iterator": "^6.0.0",
# "phpunit/php-invoker": "^6.0.0",
# "phpunit/php-text-template": "^5.0.0",
@@ -116,7 +116,7 @@ Requires: php-xmlwriter
Requires: (php-composer(myclabs/deep-copy) >= 1.12.1 with php-composer(myclabs/deep-copy) < 2)
Requires: (php-composer(phar-io/manifest) >= 2.0.4 with php-composer(phar-io/manifest) < 3)
Requires: (php-composer(phar-io/version) >= 3.2.1 with php-composer(phar-io/version) < 4)
-Requires: (php-composer(phpunit/php-code-coverage) >= 12.0.0 with php-composer(phpunit/php-code-coverage) < 13)
+Requires: (php-composer(phpunit/php-code-coverage) >= 12.0.2 with php-composer(phpunit/php-code-coverage) < 13)
Requires: (php-composer(phpunit/php-file-iterator) >= 6.0.0 with php-composer(phpunit/php-file-iterator) < 7)
Requires: (php-composer(phpunit/php-invoker) >= 6.0.0 with php-composer(phpunit/php-invoker) < 7)
Requires: (php-composer(phpunit/php-text-template) >= 5.0.0 with php-composer(phpunit/php-text-template) < 6)
@@ -153,7 +153,7 @@ It is an instance of the xUnit architecture for unit testing frameworks.
This package provides the version %{ver_major} of PHPUnit,
available using the %{name} command.
-Documentation: https://phpunit.readthedocs.io/
+Documentation: https://phpunit.de/documentation.html
%prep
@@ -285,6 +285,9 @@ exit $ret
%changelog
+* Sun Feb 9 2025 Remi Collet <remi@remirepo.net> - 12.0.2-1
+- update to 12.0.2
+
* Fri Feb 7 2025 Remi Collet <remi@remirepo.net> - 12.0.1-1
- update to 12.0.1
- raise dependency on PHP 8.3