summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--phpunit11.spec16
2 files changed, 11 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index b1c750b..c56e47f 100644
--- a/composer.json
+++ b/composer.json
@@ -39,7 +39,7 @@
"phpunit/php-timer": "^7.0.1",
"sebastian/cli-parser": "^3.0.2",
"sebastian/code-unit": "^3.0.1",
- "sebastian/comparator": "^6.0.2",
+ "sebastian/comparator": "^6.1.0",
"sebastian/diff": "^6.0.2",
"sebastian/environment": "^7.2.0",
"sebastian/exporter": "^6.1.3",
diff --git a/phpunit11.spec b/phpunit11.spec
index 7b69e89..4e8c022 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit d2ef57db1410b102b250e0cdce6675a60c2a993d
-%global gh_date 2024-09-09
+%global gh_commit 4dc07a589a68f8f2d5132ac0849146d122e08347
+%global gh_date 2024-09-13
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -34,7 +34,7 @@
%global ver_major 11
%global ver_minor 3
-%global upstream_version 11.3.4
+%global upstream_version 11.3.5
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -63,7 +63,7 @@ BuildRequires: (php-composer(phpunit/php-text-template) >= 4.0.1 with php-c
BuildRequires: (php-composer(phpunit/php-timer) >= 7.0.1 with php-composer(phpunit/php-timer) < 8)
BuildRequires: (php-composer(sebastian/cli-parser) >= 3.0.2 with php-composer(sebastian/cli-parser) < 4)
BuildRequires: (php-composer(sebastian/code-unit) >= 3.0.1 with php-composer(sebastian/code-unit) < 4)
-BuildRequires: (php-composer(sebastian/comparator) >= 6.0.2 with php-composer(sebastian/comparator) < 7)
+BuildRequires: (php-composer(sebastian/comparator) >= 6.1.0 with php-composer(sebastian/comparator) < 7)
BuildRequires: (php-composer(sebastian/diff) >= 6.0.2 with php-composer(sebastian/diff) < 7)
BuildRequires: (php-composer(sebastian/environment) >= 7.2.0 with php-composer(sebastian/environment) < 8)
BuildRequires: (php-composer(sebastian/exporter) >= 6.1.3 with php-composer(sebastian/exporter) < 7)
@@ -98,7 +98,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "phpunit/php-timer": "^7.0.1",
# "sebastian/cli-parser": "^3.0.2",
# "sebastian/code-unit": "^3.0.1",
-# "sebastian/comparator": "^6.0.2",
+# "sebastian/comparator": "^6.1.0",
# "sebastian/diff": "^6.0.2",
# "sebastian/environment": "^7.2.0",
# "sebastian/exporter": "^6.1.3",
@@ -124,7 +124,7 @@ Requires: (php-composer(phpunit/php-text-template) >= 4.0.1 with php-c
Requires: (php-composer(phpunit/php-timer) >= 7.0.1 with php-composer(phpunit/php-timer) < 8)
Requires: (php-composer(sebastian/cli-parser) >= 3.0.2 with php-composer(sebastian/cli-parser) < 4)
Requires: (php-composer(sebastian/code-unit) >= 3.0.1 with php-composer(sebastian/code-unit) < 4)
-Requires: (php-composer(sebastian/comparator) >= 6.0.2 with php-composer(sebastian/comparator) < 7)
+Requires: (php-composer(sebastian/comparator) >= 6.1.0 with php-composer(sebastian/comparator) < 7)
Requires: (php-composer(sebastian/diff) >= 6.0.2 with php-composer(sebastian/diff) < 7)
Requires: (php-composer(sebastian/environment) >= 7.2.0 with php-composer(sebastian/environment) < 8)
Requires: (php-composer(sebastian/exporter) >= 6.1.3 with php-composer(sebastian/exporter) < 7)
@@ -266,6 +266,10 @@ exit $ret
%changelog
+* Fri Sep 13 2024 Remi Collet <remi@remirepo.net> - 11.3.5-1
+- update to 11.3.5
+- raise dependency on sebastian/comparator 6.1.0
+
* Mon Sep 9 2024 Remi Collet <remi@remirepo.net> - 11.3.4-1
- update to 11.3.4