summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json3
-rw-r--r--phpunit11.spec12
2 files changed, 10 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index f91b4cc..4d32a94 100644
--- a/composer.json
+++ b/composer.json
@@ -74,6 +74,7 @@
"tests/"
],
"files": [
+ "tests/_files/deprecation-trigger/trigger_deprecation.php",
"tests/_files/CoverageNamespacedFunctionTest.php",
"tests/_files/CoveredFunction.php",
"tests/_files/Generator.php",
@@ -82,7 +83,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "11.0-dev"
+ "dev-main": "11.1-dev"
}
}
}
diff --git a/phpunit11.spec b/phpunit11.spec
index bf9bfa0..e5cc6bc 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit 591bbfe416400385527d5086b346b92c06de404b
-%global gh_date 2024-03-28
+%global gh_commit 882c5bf7aa85328d1010da2a76f4bb10c43778c6
+%global gh_date 2024-04-05
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -32,9 +32,9 @@
%global ns_vendor PHPUnit11
%global php_home %{_datadir}/php
%global ver_major 11
-%global ver_minor 0
+%global ver_minor 1
-%global upstream_version 11.0.9
+%global upstream_version 11.1.0
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -261,6 +261,7 @@ cat src/autoload.php
cat << 'EOF' | tee -a tests/autoload.php
// Dependencies
\Fedora\Autoloader\Dependencies::required([
+ __DIR__ . '/_files/deprecation-trigger/trigger_deprecation.php',
__DIR__ . '/_files/CoverageNamespacedFunctionTest.php',
__DIR__ . '/_files/CoveredFunction.php',
__DIR__ . '/_files/NamespaceCoveredFunction.php',
@@ -313,6 +314,9 @@ exit $ret
%changelog
+* Fri Apr 5 2024 Remi Collet <remi@remirepo.net> - 11.1.0-1
+- update to 11.1.0
+
* Thu Mar 28 2024 Remi Collet <remi@remirepo.net> - 11.0.9-1
- update to 11.0.9