summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--phpunit11-rpm.patch6
-rw-r--r--phpunit11.spec9
2 files changed, 10 insertions, 5 deletions
diff --git a/phpunit11-rpm.patch b/phpunit11-rpm.patch
index b8e069b..ec83474 100644
--- a/phpunit11-rpm.patch
+++ b/phpunit11-rpm.patch
@@ -69,11 +69,13 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
}
if ($notLatest) {
-@@ -54,6 +55,7 @@ final readonly class VersionCheckCommand
+@@ -54,6 +55,9 @@ final readonly class VersionCheckCommand
'The latest version is PHPUnit %s.' . PHP_EOL,
$latestVersion,
);
-+ $buffer .= sprintf('Try to install and use the phpunit%s command.' . PHP_EOL, explode('.', $latestVersion)[0]);
++ if ($major !== ($new = (int)explode('.', $latestVersion)[0])) {
++ $buffer .= sprintf('Try to install and use the phpunit%d command.' . PHP_EOL, $new);
++ }
}
return Result::from($buffer, Result::FAILURE);
diff --git a/phpunit11.spec b/phpunit11.spec
index f4fa447..1dcdd35 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit 6af32d7938fc366f86e49a5f5ebb314018d1b1fb
-%global gh_date 2024-03-12
+%global gh_commit afa8d61ba7ae78da739938c999140eb767a1ad7f
+%global gh_date 2024-03-21
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -34,7 +34,7 @@
%global ver_major 11
%global ver_minor 0
-%global upstream_version 11.0.6
+%global upstream_version 11.0.7
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -313,6 +313,9 @@ exit $ret
%changelog
+* Thu Mar 21 2024 Remi Collet <remi@remirepo.net> - 11.0.7-1
+- update to 11.0.7
+
* Wed Mar 13 2024 Remi Collet <remi@remirepo.net> - 11.0.6-1
- update to 11.0.6