summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rwxr-xr-xmakesrc.sh4
-rw-r--r--phpunit11-rpm.patch32
-rw-r--r--phpunit11.spec11
4 files changed, 27 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index 8bc9364..9653c26 100644
--- a/composer.json
+++ b/composer.json
@@ -83,7 +83,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "11.2-dev"
+ "dev-main": "11.3-dev"
}
}
}
diff --git a/makesrc.sh b/makesrc.sh
index 04ad6a0..5e25d18 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -19,7 +19,9 @@ else
echo "Cloning..."
rm -rf $PROJECT-$COMMIT
- git clone --branch $MAJOR.$MINOR --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1
+ git clone --branch $MAJOR.$MINOR --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || \
+ git clone --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || \
+ exit 1
echo "Getting commit..."
pushd $PROJECT-$COMMIT
diff --git a/phpunit11-rpm.patch b/phpunit11-rpm.patch
index d117536..10b1cc7 100644
--- a/phpunit11-rpm.patch
+++ b/phpunit11-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2024-03-21 10:23:39.000000000 +0100
-+++ ./phpunit 2024-03-21 14:04:08.699638712 +0100
+--- ./phpunit.rpm 2024-08-02 08:11:38.000000000 +0200
++++ ./phpunit 2024-08-02 08:12:01.101893244 +0200
@@ -46,27 +46,13 @@ if (isset($GLOBALS['_composer_autoload_p
define('PHPUNIT_COMPOSER_INSTALL', $GLOBALS['_composer_autoload_path']);
@@ -50,18 +50,18 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main();
+}
diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/Command/Commands/VersionCheckCommand.php
---- ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm 2024-03-21 10:23:39.000000000 +0100
-+++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-03-21 14:04:31.164578940 +0100
-@@ -24,7 +24,7 @@ final readonly class VersionCheckCommand
- public function execute(): Result
- {
- $latestVersion = file_get_contents('https://phar.phpunit.de/latest-version-of/phpunit');
+--- ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm 2024-08-02 08:11:38.000000000 +0200
++++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-08-02 08:13:24.053211780 +0200
+@@ -31,7 +31,7 @@ final readonly class VersionCheckCommand
+
+ assert($latestVersion !== false);
+
- $latestCompatibleVersion = @file_get_contents('https://phar.phpunit.de/latest-version-of/phpunit-' . Version::majorVersionNumber());
+ $latestCompatibleVersion = @file_get_contents('https://phar.phpunit.de/latest-version-of/phpunit-' . $major=Version::majorVersionNumber());
$notLatest = version_compare($latestVersion, Version::id(), '>');
$notLatestCompatible = false;
-@@ -39,7 +39,7 @@ final readonly class VersionCheckCommand
+@@ -46,7 +46,7 @@ final readonly class VersionCheckCommand
);
}
@@ -70,7 +70,7 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
if ($notLatestCompatible) {
$buffer .= sprintf(
-@@ -47,6 +47,7 @@ final readonly class VersionCheckCommand
+@@ -54,6 +54,7 @@ final readonly class VersionCheckCommand
Version::id(),
$latestCompatibleVersion,
);
@@ -78,7 +78,7 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
}
if ($notLatest) {
-@@ -54,6 +55,9 @@ final readonly class VersionCheckCommand
+@@ -61,6 +62,9 @@ final readonly class VersionCheckCommand
'The latest version is PHPUnit %s.' . PHP_EOL,
$latestVersion,
);
@@ -89,9 +89,9 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
return Result::from($buffer, Result::FAILURE);
diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Configuration/Xml/SchemaFinder.php
---- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2024-03-21 10:23:39.000000000 +0100
-+++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2024-03-21 14:04:08.699638712 +0100
-@@ -75,6 +75,6 @@ final readonly class SchemaFinder
+--- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2024-08-02 08:11:38.000000000 +0200
++++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2024-08-02 08:12:01.102893284 +0200
+@@ -77,6 +77,6 @@ final readonly class SchemaFinder
return __PHPUNIT_PHAR_ROOT__ . '/';
}
@@ -100,8 +100,8 @@ diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Config
}
}
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2024-03-21 10:23:39.000000000 +0100
-+++ ./tests/bootstrap.php 2024-03-21 14:04:08.699638712 +0100
+--- ./tests/bootstrap.php.rpm 2024-08-02 08:11:38.000000000 +0200
++++ ./tests/bootstrap.php 2024-08-02 08:12:01.102893284 +0200
@@ -11,8 +11,8 @@ if (!defined('TEST_FILES_PATH')) {
define('TEST_FILES_PATH', __DIR__ . DIRECTORY_SEPARATOR . '_files' . DIRECTORY_SEPARATOR);
}
diff --git a/phpunit11.spec b/phpunit11.spec
index 8f6a49d..5540dbe 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit c197bbaaca360efda351369bf1fd9cc1ca6bcbf7
-%global gh_date 2024-07-30
+%global gh_commit a8dce73a8938dfec7ac0daa91bdbcaae7d7188a3
+%global gh_date 2024-08-02
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -32,9 +32,9 @@
%global ns_vendor PHPUnit11
%global php_home %{_datadir}/php
%global ver_major 11
-%global ver_minor 2
+%global ver_minor 3
-%global upstream_version 11.2.9
+%global upstream_version 11.3.0
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -266,6 +266,9 @@ exit $ret
%changelog
+* Fri Aug 2 2024 Remi Collet <remi@remirepo.net> - 11.3.0-1
+- update to 11.3.0
+
* Tue Jul 30 2024 Remi Collet <remi@remirepo.net> - 11.2.9-1
- update to 11.2.9