summaryrefslogtreecommitdiffstats
path: root/phpunit11.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-07-02 09:50:03 +0200
committerRemi Collet <remi@php.net>2024-07-02 09:50:03 +0200
commitcac1da54224395d5ca4c11c5d5aa27c8e1f84754 (patch)
tree0d14eda1f85c04de347c2be40f05178bc13cf8d2 /phpunit11.spec
parent22184b049b630542fb98aa8eb7f3c2028743c85c (diff)
update to 11.2.5
raise dependency on sebastian/exporter 6.1.2
Diffstat (limited to 'phpunit11.spec')
-rw-r--r--phpunit11.spec20
1 files changed, 12 insertions, 8 deletions
diff --git a/phpunit11.spec b/phpunit11.spec
index f79bfd1..b7ccef3 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit 1b8775732e9c401bda32df3ffbdf90dec7533ceb
-%global gh_date 2024-06-11
+%global gh_commit be9e3ed32a1287a9bfda15936cc86fef4e4cf591
+%global gh_date 2024-06-20
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -34,7 +34,7 @@
%global ver_major 11
%global ver_minor 2
-%global upstream_version 11.2.1
+%global upstream_version 11.2.5
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -68,7 +68,7 @@ BuildRequires: (php-composer(sebastian/code-unit) >= 3.0 with php-c
BuildRequires: (php-composer(sebastian/comparator) >= 6.0 with php-composer(sebastian/comparator) < 7)
BuildRequires: (php-composer(sebastian/diff) >= 6.0 with php-composer(sebastian/diff) < 7)
BuildRequires: (php-composer(sebastian/environment) >= 7.0 with php-composer(sebastian/environment) < 8)
-BuildRequires: (php-composer(sebastian/exporter) >= 6.0 with php-composer(sebastian/exporter) < 7)
+BuildRequires: (php-composer(sebastian/exporter) >= 6.1.2 with php-composer(sebastian/exporter) < 7)
BuildRequires: (php-composer(sebastian/global-state) >= 7.0 with php-composer(sebastian/global-state) < 8)
BuildRequires: (php-composer(sebastian/object-enumerator) >= 6.0 with php-composer(sebastian/object-enumerator) < 7)
BuildRequires: (php-composer(sebastian/type) >= 5.0 with php-composer(sebastian/type) < 6)
@@ -88,7 +88,7 @@ BuildRequires: php-sebastian-code-unit3
BuildRequires: php-sebastian-comparator6
BuildRequires: php-sebastian-diff6
BuildRequires: php-sebastian-environment7
-BuildRequires: php-sebastian-exporter6
+BuildRequires: php-sebastian-exporter6 >= 6.1.2
BuildRequires: php-sebastian-global-state7
BuildRequires: php-sebastian-object-enumerator6
BuildRequires: php-sebastian-type5
@@ -124,7 +124,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "sebastian/comparator": "^6.0",
# "sebastian/diff": "^6.0",
# "sebastian/environment": "^7.0",
-# "sebastian/exporter": "^6.0",
+# "sebastian/exporter": "^6.1.2",
# "sebastian/global-state": "^7.0",
# "sebastian/object-enumerator": "^6.0",
# "sebastian/type": "^5.0",
@@ -152,7 +152,7 @@ Requires: (php-composer(sebastian/code-unit) >= 3.0 with php-c
Requires: (php-composer(sebastian/comparator) >= 6.0 with php-composer(sebastian/comparator) < 7)
Requires: (php-composer(sebastian/diff) >= 6.0 with php-composer(sebastian/diff) < 7)
Requires: (php-composer(sebastian/environment) >= 7.0 with php-composer(sebastian/environment) < 8)
-Requires: (php-composer(sebastian/exporter) >= 6.0 with php-composer(sebastian/exporter) < 7)
+Requires: (php-composer(sebastian/exporter) >= 6.1.2 with php-composer(sebastian/exporter) < 7)
Requires: (php-composer(sebastian/global-state) >= 7.0 with php-composer(sebastian/global-state) < 8)
Requires: (php-composer(sebastian/object-enumerator) >= 6.0 with php-composer(sebastian/object-enumerator) < 7)
Requires: (php-composer(sebastian/type) >= 5.0 with php-composer(sebastian/type) < 6)
@@ -177,7 +177,7 @@ Requires: php-sebastian-code-unit3
Requires: php-sebastian-comparator6
Requires: php-sebastian-diff6
Requires: php-sebastian-environment7
-Requires: php-sebastian-exporter6
+Requires: php-sebastian-exporter6 >= 6.1.2
Requires: php-sebastian-global-state7
Requires: php-sebastian-object-enumerator6
Requires: php-sebastian-type5
@@ -314,6 +314,10 @@ exit $ret
%changelog
+* Tue Jul 2 2024 Remi Collet <remi@remirepo.net> - 11.2.5-1
+- update to 11.2.5
+- raise dependency on sebastian/exporter 6.1.2
+
* Tue Jun 11 2024 Remi Collet <remi@remirepo.net> - 11.2.1-1
- update to 11.2.1