summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-04-24 11:09:51 +0200
committerRemi Collet <remi@php.net>2024-04-24 11:09:51 +0200
commite6082c99333448e2a2636b881aa95a0827aca1fd (patch)
treee409ae5f7ea7ec32bec7ba823eceffb4a2eb799b
parentbc89b076937b71a3f7d6281f95e10e8993cc555d (diff)
update to 11.1.3HEADmaster
-rwxr-xr-xmakesrc.sh6
-rw-r--r--phpunit11.spec9
2 files changed, 10 insertions, 5 deletions
diff --git a/makesrc.sh b/makesrc.sh
index f99ef28..04ad6a0 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -5,10 +5,12 @@ DATE=$(sed -n '/^%global gh_date/{s/.* //;p}' $NAME.spec)
OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
VERSION=$(sed -n '/^%global upstream_version/{s/.* //;p}' $NAME.spec)
+MAJOR=$(sed -n '/^%global ver_major/{s/.* //;p}' $NAME.spec)
+MINOR=$(sed -n '/^%global ver_minor/{s/.* //;p}' $NAME.spec)
COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
SHORT=${COMMIT:0:7}
-DATE=$(date -d "$DATE -5 days" +%Y-%m-%d)
+DATE=$(date -d "$DATE -1 week" +%Y-%m-%d)
if [ -f $NAME-$VERSION-$SHORT.tgz ]; then
echo "$NAME-$VERSION-$SHORT.tgz already there"
@@ -17,7 +19,7 @@ else
echo "Cloning..."
rm -rf $PROJECT-$COMMIT
- git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1
+ git clone --branch $MAJOR.$MINOR --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1
echo "Getting commit..."
pushd $PROJECT-$COMMIT
diff --git a/phpunit11.spec b/phpunit11.spec
index 090d696..55bce21 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit 51e342a0bc987e0ea8418105d0711f08ae116de3
-%global gh_date 2024-04-14
+%global gh_commit d475be032238173ca3b0a516f5cc291d174708ae
+%global gh_date 2024-04-24
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -34,7 +34,7 @@
%global ver_major 11
%global ver_minor 1
-%global upstream_version 11.1.2
+%global upstream_version 11.1.3
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -314,6 +314,9 @@ exit $ret
%changelog
+* Wed Apr 24 2024 Remi Collet <remi@remirepo.net> - 11.1.3-1
+- update to 11.1.3
+
* Mon Apr 15 2024 Remi Collet <remi@remirepo.net> - 11.1.2-1
- update to 11.1.2